summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox_2.0.0.3.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2008-02-25 00:56:11 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2008-02-25 00:56:11 +0000
commita5a529f7e8855b28ac80a0854ebde5efd13afe6d (patch)
tree85b30a460d2d2f73c944cd71bfaae0bdd74be24f /packages/mozilla/firefox_2.0.0.3.bb
parent89edf25da6cbf515358aaa5fd64987d2a04bbc4f (diff)
parent626030cab71d4fd02092e25aeff27f2b87d3e257 (diff)
merge of '7460b51ee9cc9d17b403416ed3a84895ac86e667'
and 'cad8e5a9c094705cd6895a456eac5da6d41967bb'
Diffstat (limited to 'packages/mozilla/firefox_2.0.0.3.bb')
-rw-r--r--packages/mozilla/firefox_2.0.0.3.bb26
1 files changed, 12 insertions, 14 deletions
diff --git a/packages/mozilla/firefox_2.0.0.3.bb b/packages/mozilla/firefox_2.0.0.3.bb
index e1fb5a996d..72c42bc074 100644
--- a/packages/mozilla/firefox_2.0.0.3.bb
+++ b/packages/mozilla/firefox_2.0.0.3.bb
@@ -6,38 +6,36 @@ SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/
file://no-xmb.patch;patch=1 \
file://jsautocfg.h \
file://extensions-hack.patch;patch=1 \
- file://security-cross.patch;patch=1 \
- file://jsautocfg-dontoverwrite.patch;patch=1 \
- file://xptcinvoke-arm.patch;patch=1 \
- file://eabi-fix.patch;patch=1 \
- file://eabi-fix2.patch;patch=1 \
- file://eabi-fix3.patch;patch=1 \
- file://linkage-problem.patch;patch=1 \
- "
+ file://security-cross.patch;patch=1 \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+ file://xptcinvoke-arm.patch;patch=1 \
+ file://eabi-fix.patch;patch=1 \
+ file://eabi-fix2.patch;patch=1 \
+ file://eabi-fix3.patch;patch=1 \
+ file://linkage-problem.patch;patch=1 \
+"
S = "${WORKDIR}/mozilla"
DEFAULT_PREFERENCE = "-1"
inherit mozilla
-
require firefox.inc
do_compile_prepend() {
cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
-
sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
}
do_stage() {
-
- install -d ${STAGING_INCDIR}/${P}
+ install -d ${STAGING_INCDIR}/firefox-${PV}
cd dist/sdk/include
+ rm -rf obsolete
headers=`find . -name "*.h"`
for f in $headers
do
- install -D -m 0644 $f ${STAGING_INCDIR}/${P}/$f
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
done
# removes 2 lines that call absent headers
- sed -e '178,179d' ${STAGING_INCDIR}/${P}/nsIServiceManager.h
+ sed -e '178,179d' ${STAGING_INCDIR}/firefox-${PV}/nsIServiceManager.h
}