summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox_2.0.0.3.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2008-02-21 16:19:39 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2008-02-21 16:19:39 +0000
commit5a780d6069d6bf4ed678cb2ebe1d907c8df71df1 (patch)
tree67d78e629cf61e8d0a9a5752af352eec9415d6af /packages/mozilla/firefox_2.0.0.3.bb
parentaec20185812f752b04917ebda2293440ace6b3db (diff)
parentfc8bb1b8fad9b45a31b5b1081fb6c8a67d0654db (diff)
merge of '6c2d621bdfd446c13552a5e4b126ef9c5dd20106'
and 'f8d54cc4c0dfc594e55d38708db17f5d5c68846a'
Diffstat (limited to 'packages/mozilla/firefox_2.0.0.3.bb')
-rw-r--r--packages/mozilla/firefox_2.0.0.3.bb26
1 files changed, 12 insertions, 14 deletions
diff --git a/packages/mozilla/firefox_2.0.0.3.bb b/packages/mozilla/firefox_2.0.0.3.bb
index e1fb5a996d..72c42bc074 100644
--- a/packages/mozilla/firefox_2.0.0.3.bb
+++ b/packages/mozilla/firefox_2.0.0.3.bb
@@ -6,38 +6,36 @@ SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/
file://no-xmb.patch;patch=1 \
file://jsautocfg.h \
file://extensions-hack.patch;patch=1 \
- file://security-cross.patch;patch=1 \
- file://jsautocfg-dontoverwrite.patch;patch=1 \
- file://xptcinvoke-arm.patch;patch=1 \
- file://eabi-fix.patch;patch=1 \
- file://eabi-fix2.patch;patch=1 \
- file://eabi-fix3.patch;patch=1 \
- file://linkage-problem.patch;patch=1 \
- "
+ file://security-cross.patch;patch=1 \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+ file://xptcinvoke-arm.patch;patch=1 \
+ file://eabi-fix.patch;patch=1 \
+ file://eabi-fix2.patch;patch=1 \
+ file://eabi-fix3.patch;patch=1 \
+ file://linkage-problem.patch;patch=1 \
+"
S = "${WORKDIR}/mozilla"
DEFAULT_PREFERENCE = "-1"
inherit mozilla
-
require firefox.inc
do_compile_prepend() {
cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
-
sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
}
do_stage() {
-
- install -d ${STAGING_INCDIR}/${P}
+ install -d ${STAGING_INCDIR}/firefox-${PV}
cd dist/sdk/include
+ rm -rf obsolete
headers=`find . -name "*.h"`
for f in $headers
do
- install -D -m 0644 $f ${STAGING_INCDIR}/${P}/$f
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
done
# removes 2 lines that call absent headers
- sed -e '178,179d' ${STAGING_INCDIR}/${P}/nsIServiceManager.h
+ sed -e '178,179d' ${STAGING_INCDIR}/firefox-${PV}/nsIServiceManager.h
}