summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox_2.0.0.1.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-02-12 21:49:14 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-02-12 21:49:14 +0000
commit4ff8b59a986c1d737129603a026a33b6cb016686 (patch)
treeff82a77683170e5060a222b695edb4afc2829ac1 /packages/mozilla/firefox_2.0.0.1.bb
parent61cd1b840978cd8e3afdb1c643557d5b1b9a4a98 (diff)
firefox_2.0.0.1.bb : add new version of firefox with a couple of patches
that make it actually run further than before. If now segfaults after running at 100% cpu for a while. But I cant get arm gdb to give me sensible debugging at the segfault.
Diffstat (limited to 'packages/mozilla/firefox_2.0.0.1.bb')
-rw-r--r--packages/mozilla/firefox_2.0.0.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/mozilla/firefox_2.0.0.1.bb b/packages/mozilla/firefox_2.0.0.1.bb
new file mode 100644
index 0000000000..db3c0f4902
--- /dev/null
+++ b/packages/mozilla/firefox_2.0.0.1.bb
@@ -0,0 +1,37 @@
+PR = "r1"
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://jsautocfg.h \
+ file://extensions-hack.patch;patch=1 \
+ file://security-cross.patch;patch=1 \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+ file://xptcinvoke-arm.patch;patch=1 \
+ file://jsdtoa-float-type.patch;patch=1 \
+ "
+S = "${WORKDIR}/mozilla"
+DEFAULT_PREFERENCE = "-1"
+
+inherit mozilla
+
+require firefox.inc
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+
+ sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
+}
+
+do_stage() {
+
+ install -d ${STAGING_INCDIR}/${P}
+ cd dist/sdk/include
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/${P}/$f
+ done
+ # removes 2 lines that call absent headers
+ sed -e '178,179d' ${STAGING_INCDIR}/${P}/nsIServiceManager.h
+}
+