summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox_2.0.0.1.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-02-15 06:36:07 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-02-15 06:36:07 +0000
commit154641298d7cb2c336bc6a5a38e51d9f7e14abc2 (patch)
tree98bc3958b1f6473ff24001701b608f0a86c556a8 /packages/mozilla/firefox_2.0.0.1.bb
parentd761c689e1a013a698f5b032cb95d516c7ba22da (diff)
parent1c4bf67a97a157e0d7cf5756f29f78bac1139a57 (diff)
merge of '0c4f9a61dfdb0b3267c7794453ccf15dbc4e600c'
and 'd99679b234416670dd8c8e3c87704e7479b4a1e2'
Diffstat (limited to 'packages/mozilla/firefox_2.0.0.1.bb')
-rw-r--r--packages/mozilla/firefox_2.0.0.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/mozilla/firefox_2.0.0.1.bb b/packages/mozilla/firefox_2.0.0.1.bb
new file mode 100644
index 0000000000..db3c0f4902
--- /dev/null
+++ b/packages/mozilla/firefox_2.0.0.1.bb
@@ -0,0 +1,37 @@
+PR = "r1"
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://jsautocfg.h \
+ file://extensions-hack.patch;patch=1 \
+ file://security-cross.patch;patch=1 \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+ file://xptcinvoke-arm.patch;patch=1 \
+ file://jsdtoa-float-type.patch;patch=1 \
+ "
+S = "${WORKDIR}/mozilla"
+DEFAULT_PREFERENCE = "-1"
+
+inherit mozilla
+
+require firefox.inc
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+
+ sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
+}
+
+do_stage() {
+
+ install -d ${STAGING_INCDIR}/${P}
+ cd dist/sdk/include
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/${P}/$f
+ done
+ # removes 2 lines that call absent headers
+ sed -e '178,179d' ${STAGING_INCDIR}/${P}/nsIServiceManager.h
+}
+