summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox_1.5.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2005-12-14 09:05:45 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-12-14 09:05:45 +0000
commit11fdccc123014b571f6634ccaf27c573cbff2030 (patch)
treec632138e33f51e1c97df8c95060af225ccac8d0e /packages/mozilla/firefox_1.5.bb
parent012b9a75e3a543e7389c518ba0ca104e5fd5da36 (diff)
firefox-1.5 : remove beta version and add the release version of 1.5 currently at DEFAULT_PREFERENCE=-1 as it doesnt work under gpe on my machine, runs but never opens any windows.
Diffstat (limited to 'packages/mozilla/firefox_1.5.bb')
-rw-r--r--packages/mozilla/firefox_1.5.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/mozilla/firefox_1.5.bb b/packages/mozilla/firefox_1.5.bb
new file mode 100644
index 0000000000..95c9509b69
--- /dev/null
+++ b/packages/mozilla/firefox_1.5.bb
@@ -0,0 +1,18 @@
+PR = "r0"
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://jsautocfg.h \
+ file://extensions-hack.patch;patch=1"
+
+S = "${WORKDIR}/mozilla"
+DEFAULT_PREFERENCE = "-1"
+
+inherit mozilla
+
+include firefox.inc
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+}
+