summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox-2.0.0.1/mult-crash-fix.patch
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-02-12 21:49:14 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-02-12 21:49:14 +0000
commit4ff8b59a986c1d737129603a026a33b6cb016686 (patch)
treeff82a77683170e5060a222b695edb4afc2829ac1 /packages/mozilla/firefox-2.0.0.1/mult-crash-fix.patch
parent61cd1b840978cd8e3afdb1c643557d5b1b9a4a98 (diff)
firefox_2.0.0.1.bb : add new version of firefox with a couple of patches
that make it actually run further than before. If now segfaults after running at 100% cpu for a while. But I cant get arm gdb to give me sensible debugging at the segfault.
Diffstat (limited to 'packages/mozilla/firefox-2.0.0.1/mult-crash-fix.patch')
-rw-r--r--packages/mozilla/firefox-2.0.0.1/mult-crash-fix.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/packages/mozilla/firefox-2.0.0.1/mult-crash-fix.patch b/packages/mozilla/firefox-2.0.0.1/mult-crash-fix.patch
new file mode 100644
index 0000000000..cb30f896ed
--- /dev/null
+++ b/packages/mozilla/firefox-2.0.0.1/mult-crash-fix.patch
@@ -0,0 +1,14 @@
+$OpenBSD: patch-nsprpub_pr_src_misc_prdtoa_c,v 1.1 2005/11/03 00:59:43 pvalchev Exp $
+Index: mozilla/nsprpub/pr/src/misc/prdtoa.c
+===================================================================
+--- mozilla.orig/nsprpub/pr/src/misc/prdtoa.c
++++ mozilla/nsprpub/pr/src/misc/prdtoa.c
+@@ -855,7 +855,7 @@ mult
+ wc = wa + wb;
+ if (wc > a->maxwds)
+ k++;
+- c = Balloc(k);
++ c = Balloc(k*2);
+ for(x = c->x, xa = x + wc; x < xa; x++)
+ *x = 0;
+ xa = a->x;