summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox-2.0.0.1/mozconfig
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-02-12 21:49:14 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-02-12 21:49:14 +0000
commit4ff8b59a986c1d737129603a026a33b6cb016686 (patch)
treeff82a77683170e5060a222b695edb4afc2829ac1 /packages/mozilla/firefox-2.0.0.1/mozconfig
parent61cd1b840978cd8e3afdb1c643557d5b1b9a4a98 (diff)
firefox_2.0.0.1.bb : add new version of firefox with a couple of patches
that make it actually run further than before. If now segfaults after running at 100% cpu for a while. But I cant get arm gdb to give me sensible debugging at the segfault.
Diffstat (limited to 'packages/mozilla/firefox-2.0.0.1/mozconfig')
-rw-r--r--packages/mozilla/firefox-2.0.0.1/mozconfig57
1 files changed, 57 insertions, 0 deletions
diff --git a/packages/mozilla/firefox-2.0.0.1/mozconfig b/packages/mozilla/firefox-2.0.0.1/mozconfig
new file mode 100644
index 0000000000..9737330a77
--- /dev/null
+++ b/packages/mozilla/firefox-2.0.0.1/mozconfig
@@ -0,0 +1,57 @@
+. $topsrcdir/browser/config/mozconfig
+
+# use GTK+-2 widget set with XFT font rendering
+ac_add_options --enable-default-toolkit=gtk2
+ac_add_options --enable-xft
+ac_add_options --disable-freetype2
+
+# enable minimal profile support
+ac_add_options --disable-profilesharing
+ac_add_options --disable-profilelocking
+ac_add_options --enable-single-profile
+
+ac_add_options --with-system-zlib
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-png
+
+ac_add_options --disable-accessibility
+ac_add_options --disable-composer
+#ac_add_options --enable-plaintext-editor-only
+ac_add_options --disable-mailnews
+ac_add_options --disable-ldap
+#ac_add_options --disable-postscript
+ac_add_options --disable-mathml
+ac_add_options --disable-jsd
+ac_add_options --disable-installer
+ac_add_options --disable-xprint
+ac_add_options --disable-necko-disk-cache
+
+# configure necko to allocate smaller network buffers
+ac_add_options --enable-necko-small-buffers
+
+# disable debug logging and tests
+#ac_add_options --disable-dtd-debug
+ac_add_options --disable-logging
+ac_add_options --enable-debug=-ggdb
+ac_add_options --disable-gtktest
+ac_add_options --disable-tests
+ac_add_options --disable-printing
+ac_add_options --disable-gnomevfs
+ac_add_options --disable-gnomeui
+
+# build crypto module (PSM + NSS)
+ac_add_options --enable-crypto
+
+# build minimal set of protocol handlers
+ac_add_options --enable-necko-protocols=http,file,res,jar,ftp,about,viewsource
+
+# build minimal set of image decoders
+ac_add_options --enable-image-decoders=png,gif,jpeg
+
+#ac_add_options --enable-reorder
+#ac_add_options --enable-elf-dynstr-gc
+
+# enable static build
+#ac_add_options --disable-shared
+#ac_add_options --enable-static
+ac_add_options --enable-optimize=-O1