summaryrefslogtreecommitdiff
path: root/packages/monotone
diff options
context:
space:
mode:
authorShane Volpe <shanevolpe@gmail.com>2007-04-07 20:23:43 +0000
committerShane Volpe <shanevolpe@gmail.com>2007-04-07 20:23:43 +0000
commit3a5e5c11ca9e5d3686fce546e33eacc62f5e7dcd (patch)
tree4f25aacf8558a773fad14e0018d4afb9f560237f /packages/monotone
parent1ff6665ead8253bb6adde2afeb004f9ef625f4f4 (diff)
parent2effa2e0213c0cecaf6d3a0ca7390a288ebc9908 (diff)
merge of '59b19c7d48e754418caf1f4214b1ce53d2cca5c4'
and 'f4a044e0ef8b886ef1bdc74ae09f12874ddf7130'
Diffstat (limited to 'packages/monotone')
-rw-r--r--packages/monotone/monotone-6_0.33.bb4
-rw-r--r--packages/monotone/monotone-6_0.34.bb52
2 files changed, 54 insertions, 2 deletions
diff --git a/packages/monotone/monotone-6_0.33.bb b/packages/monotone/monotone-6_0.33.bb
index 47e58a48c6..64b1d1699e 100644
--- a/packages/monotone/monotone-6_0.33.bb
+++ b/packages/monotone/monotone-6_0.33.bb
@@ -25,7 +25,7 @@ inherit autotools
#FIXME: remove the following
ARM_INSTRUCTION_SET = "arm"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://monotone.ca/downloads/${PV}/monotone-${PV}.tar.gz \
file://txt2c-cross-post-0.22.patch;patch=1 \
@@ -42,7 +42,7 @@ do_install_append() {
install -d ${D}${tsd}
install -c -m 755 testsuite ${D}${tsd}/testsuite
cp -pPR tests ${D}${tsd}/tests
- rm ${D}/home/monotone/monotone-6/tests/tests/diff_a_binary_file/binary
+ rm ${D}/home/monotone/monotone-6/tests/diff_a_binary_file/binary
}
PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
diff --git a/packages/monotone/monotone-6_0.34.bb b/packages/monotone/monotone-6_0.34.bb
new file mode 100644
index 0000000000..0442e0232e
--- /dev/null
+++ b/packages/monotone/monotone-6_0.34.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "Monotone is a distributed Source Control System"
+HOMEPAGE = "http://www.monotone.ca/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+DEPENDS = "boost"
+
+PROVIDES = "monotone"
+RPROVIDES = "monotone"
+
+S = "${WORKDIR}/monotone-${PV}"
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ --with-bundled-lua --with-bundled-sqlite"
+
+inherit autotools
+
+# Release 0.22 reveals bugs in g++ for thumb (g++ generates
+# relocations which the linker cannot represent)
+#FIXME: remove the following
+ARM_INSTRUCTION_SET = "arm"
+
+PR = "r0"
+
+SRC_URI = "http://monotone.ca/downloads/${PV}/monotone-${PV}.tar.gz \
+ file://txt2c-cross-post-0.22.patch;patch=1 \
+ file://uclibc.database.hh.stdarg.patch;patch=1 \
+ file://configure.ac-no-sync-with-stdio-0.31.patch;patch=1 \
+ "
+do_compile_append() {
+ touch testsuite
+}
+
+# This makes the testsuite as a package and renames the monotone executable
+# to include the netsync suffix.
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -pPR tests ${D}${tsd}/tests
+ rm ${D}/home/monotone/monotone-6/tests/diff_a_binary_file/binary
+}
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone/${PN}"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+RDEPENDS_${PN}-testsuite += "bash sed grep cvs patch perl perl-modules"
+