summaryrefslogtreecommitdiff
path: root/packages/monotone/monotone_0.20.bb
diff options
context:
space:
mode:
authorccsmart <ccsmart@smartpal.de>2005-07-06 18:15:03 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-06 18:15:03 +0000
commit5565996ae46389896f5a8638b98bc55811f09e9b (patch)
tree10424766ca29d2f91b751d97490e9dd3a070af40 /packages/monotone/monotone_0.20.bb
parent9c8ed5e61498f7c5537c345d92e5b2da9fd6af3d (diff)
parent060a925277aefd5367a76112c45205d3370e0a4a (diff)
merge of 39ec5c108a34c5b8050cb5c43e6e9b01d0a7e695
and bff71dff596d0325ccafbf13fc11a5beb1b38b89
Diffstat (limited to 'packages/monotone/monotone_0.20.bb')
-rw-r--r--packages/monotone/monotone_0.20.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/monotone/monotone_0.20.bb b/packages/monotone/monotone_0.20.bb
new file mode 100644
index 0000000000..dc7abc72b4
--- /dev/null
+++ b/packages/monotone/monotone_0.20.bb
@@ -0,0 +1,37 @@
+# This package builds the devio program
+DESCRIPTION = "monotone - an SCM"
+HOMEPAGE = "http://www.venge.net/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "r0"
+
+SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
+ file://txt2c-cross.patch;patch=1 \
+ file://cryptopp-endianness.patch;patch=1"
+DEPENDS += "boost"
+# Following may be required, not proved yet...
+#TARGET_CFLAGS += "-fno-strict-aliasing"
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ "
+
+inherit autotools
+
+# This makes the testsuite as a package
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -a tests ${D}${tsd}/tests
+}