summaryrefslogtreecommitdiff
path: root/packages/monotone/monotone_0.19.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-05 07:42:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-05 07:42:50 +0000
commit4c2ddb538079ad9561560f633cecfb6b429d256d (patch)
tree0180d515fffff1e49de4105998ec2bef4dbdaac7 /packages/monotone/monotone_0.19.bb
parent4def1ea71211f8abeed555475706fa331ac1b635 (diff)
Builds but has bugs in very basic functionality (db init does not work).
Diffstat (limited to 'packages/monotone/monotone_0.19.bb')
-rw-r--r--packages/monotone/monotone_0.19.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/monotone/monotone_0.19.bb b/packages/monotone/monotone_0.19.bb
new file mode 100644
index 0000000000..3bf4608970
--- /dev/null
+++ b/packages/monotone/monotone_0.19.bb
@@ -0,0 +1,34 @@
+# This package builds the devio program
+DESCRIPTION = "monotone - an SCM"
+HOMEPAGE = "http://www.venge.net/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+SUBV = "1"
+PR = "r0"
+
+SRC_URI = "http://www.venge.net/monotone/downloads/monotone_${PV}-${SUBV}.tar.gz \
+ file://txt2c-cross.patch;patch=1"
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ "
+
+inherit autotools
+
+# This makes the testsuite as a package
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -a tests ${D}${tsd}/tests
+}