summaryrefslogtreecommitdiff
path: root/packages/mono/mono-native_1.9.1.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-07-24 19:44:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-07-24 19:44:54 +0000
commitc183920a93422f7df429c7d334b1fe8ecec4e5c5 (patch)
treeadab3041805e81e3724ec71f8cdb4b36daa24e78 /packages/mono/mono-native_1.9.1.bb
parente9dd1c7d51cd7bbafd5f4d32e73d46c780b32fb1 (diff)
parentf5325f6a7630f24035776f1567594b230fb3e955 (diff)
merge of '1f4f07522c89b1ab3b65e60204a55a1a00974bc4'
and 'a8931960546bdf36307b49ffd1b252b3f0a2b108'
Diffstat (limited to 'packages/mono/mono-native_1.9.1.bb')
-rw-r--r--packages/mono/mono-native_1.9.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/mono/mono-native_1.9.1.bb b/packages/mono/mono-native_1.9.1.bb
new file mode 100644
index 0000000000..3c18cf7601
--- /dev/null
+++ b/packages/mono/mono-native_1.9.1.bb
@@ -0,0 +1,27 @@
+require mono_1.9.1.inc
+PR = "r3"
+DEPENDS = "glib-2.0-native perl-native"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += "file://mono-fix-libdir-path.patch;patch=1 \
+ file://libgc_cppflags.patch;patch=1 \
+ "
+
+PARALLEL_MAKE = ""
+
+inherit native
+
+do_stage_prepend() {
+ install -m 755 ${S}/mono/monoburg/monoburg ${STAGING_BINDIR}
+}
+
+do_fix_libtool_name() {
+ # inherit native will make that all native tools that are being
+ # built are prefixed with something like "i686-linux-",
+ # including libtool. Fix up some hardcoded libtool names:
+ for i in "${S}"/runtime/*-wrapper.in; do
+ sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
+ done
+}
+addtask fix_libtool_name after do_patch before do_configure