summaryrefslogtreecommitdiff
path: root/packages/mono/mono-mcs-intermediate_1.2.5.1.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:33:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-07 00:33:28 +0000
commit6e90aae26efa66553063b74b9afa9563b70fb982 (patch)
treedc0273068963d8e57f48f75875e5236153cf1cd9 /packages/mono/mono-mcs-intermediate_1.2.5.1.bb
parent496d5415774f03b6e09aee17763ac9432d9c2755 (diff)
parent62007cb1fac3e5a7f4a09b61c7d3c3b7cd5fc8a7 (diff)
merge of '55c714e37be4606a4166b3df883d5f404d3889bf'
and 'd714000fc8a6b75093a93f01782724b65d31eac1'
Diffstat (limited to 'packages/mono/mono-mcs-intermediate_1.2.5.1.bb')
-rw-r--r--packages/mono/mono-mcs-intermediate_1.2.5.1.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/packages/mono/mono-mcs-intermediate_1.2.5.1.bb b/packages/mono/mono-mcs-intermediate_1.2.5.1.bb
new file mode 100644
index 0000000000..813da24ddf
--- /dev/null
+++ b/packages/mono/mono-mcs-intermediate_1.2.5.1.bb
@@ -0,0 +1,61 @@
+# This is a straw-man recipe for step 1 in the two-step build of
+# mono. Because it's impossible to build the mcs directory
+# in cross-compile mode, this recipe will do a native build,
+# then tar the resulting install tree for usage by the mono
+# package in step 2.
+# See http://www.mono-project.com/Mono:ARM
+
+require mono_1.2.5.inc
+PR = "r0"
+DEPENDS = "mono-native glib-2.0-native perl-native"
+
+PARALLEL_MAKE = ""
+
+SRC_URI += "file://mono-fix-libdir-path.patch;patch=1"
+
+# Inherit native to set up compiler and paths ...
+inherit native
+# ... but override the target prefix
+prefix = "/usr"
+exec_prefix = "/usr"
+sysconfdir = "/etc"
+# TODO: Where does the mono package get
+# these paths from? Use the same source.
+
+do_fix_libtool_name() {
+ # inherit native will make that all native tools that are being
+ # built are prefixed with something like "i686-linux-",
+ # including libtool. Fix up some hardcoded libtool names:
+ for i in "${S}"/runtime/*-wrapper.in; do
+ sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
+ done
+}
+addtask fix_libtool_name after do_patch before do_configure
+
+do_stage() {
+ true
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+do_package() {
+ true
+}
+
+do_populate_staging() {
+ cd ${D}
+ rm -f ${WORKDIR}/mono-mcs-${PV}.tar.gz
+ tar -cvzf ${WORKDIR}/mono-mcs-${PV}.tar.gz .
+ install -d ${STAGING_DIR}/share/mono-mcs
+ cp ${WORKDIR}/mono-mcs-${PV}.tar.gz ${STAGING_DIR}/share/mono-mcs/
+}
+
+do_package_write_ipk() {
+ true
+}
+
+do_package_write() {
+ true
+}