summaryrefslogtreecommitdiff
path: root/packages/mono/mono-1.9.1+2.2.0-rc2
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2008-12-11 17:32:07 -0500
committerCliff Brake <cbrake@bec-systems.com>2008-12-11 17:39:45 -0500
commit08932f053357287239a6f0dc17d74981c107637c (patch)
tree6f4b2e6a8b629786e53cf718253f41c32fbf786b /packages/mono/mono-1.9.1+2.2.0-rc2
parentf31d24a7fef79438c752763eb220b4d3f9cd50bb (diff)
mono 1.9.1+2.2.0-rc2: add recipes for new version
Diffstat (limited to 'packages/mono/mono-1.9.1+2.2.0-rc2')
-rw-r--r--packages/mono/mono-1.9.1+2.2.0-rc2/configure.patch44
-rw-r--r--packages/mono/mono-1.9.1+2.2.0-rc2/disable-docs.patch13
-rw-r--r--packages/mono/mono-1.9.1+2.2.0-rc2/disable-monoburg.patch22
3 files changed, 79 insertions, 0 deletions
diff --git a/packages/mono/mono-1.9.1+2.2.0-rc2/configure.patch b/packages/mono/mono-1.9.1+2.2.0-rc2/configure.patch
new file mode 100644
index 0000000000..689f7be5da
--- /dev/null
+++ b/packages/mono/mono-1.9.1+2.2.0-rc2/configure.patch
@@ -0,0 +1,44 @@
+Index: mono-2.2/configure.in
+===================================================================
+--- mono-2.2.orig/configure.in 2008-11-13 18:22:29.000000000 -0500
++++ mono-2.2/configure.in 2008-12-10 16:03:11.000000000 -0500
+@@ -1155,6 +1155,8 @@
+ ], [
+ AC_MSG_RESULT(no)
+ with_tls=pthread
++ ], [
++ AC_MSG_RESULT(yes)
+ ])
+ fi
+
+@@ -1257,6 +1259,9 @@
+ ], [
+ with_sigaltstack=no
+ AC_MSG_RESULT(no)
++ ], [
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_WORKING_SIGALTSTACK)
+ ])
+ fi
+
+@@ -1746,6 +1751,7 @@
+
+ jit_wanted=false
+ interp_wanted=false
++echo "CLIFF: checking host = $host"
+ case "$host" in
+ # mips-sgi-irix5.* | mips-sgi-irix6.*)
+ # TARGET=MIPS;
+@@ -1882,10 +1888,12 @@
+ jit_wanted=true
+ ;;
+ arm*-linux*)
++ echo "CLIFF: found arm linux"
+ TARGET=ARM;
+ arch_target=arm;
+ ACCESS_UNALIGNED="no"
+ JIT_SUPPORTED=yes
++ CPPFLAGS="$CPPFLAGS -DARM_FPU_VFP=1"
+ jit_wanted=true
+ ;;
+ s390-*-linux*)
diff --git a/packages/mono/mono-1.9.1+2.2.0-rc2/disable-docs.patch b/packages/mono/mono-1.9.1+2.2.0-rc2/disable-docs.patch
new file mode 100644
index 0000000000..2c1812e1a5
--- /dev/null
+++ b/packages/mono/mono-1.9.1+2.2.0-rc2/disable-docs.patch
@@ -0,0 +1,13 @@
+Index: mono-2.2/Makefile.am
+===================================================================
+--- mono-2.2.orig/Makefile.am 2008-12-10 16:25:14.000000000 -0500
++++ mono-2.2/Makefile.am 2008-12-10 16:25:24.000000000 -0500
+@@ -1,7 +1,7 @@
+ AUTOMAKE_OPTIONS = foreign
+ ACLOCAL_AMFLAGS = -I .
+
+-SUBDIRS = po $(libgc_dir) $(eglib_dir) mono $(ikvm_native_dir) support data runtime scripts man samples web msvc docs
++SUBDIRS = po $(libgc_dir) $(eglib_dir) mono $(ikvm_native_dir) support data runtime scripts man samples web msvc
+
+ # Keep in sync with SUBDIRS
+ ## 'tools' is not normally built
diff --git a/packages/mono/mono-1.9.1+2.2.0-rc2/disable-monoburg.patch b/packages/mono/mono-1.9.1+2.2.0-rc2/disable-monoburg.patch
new file mode 100644
index 0000000000..14a2a094a7
--- /dev/null
+++ b/packages/mono/mono-1.9.1+2.2.0-rc2/disable-monoburg.patch
@@ -0,0 +1,22 @@
+Index: mono-2.2/mono/Makefile.am
+===================================================================
+--- mono-2.2.orig/mono/Makefile.am 2008-12-10 15:38:30.000000000 -0500
++++ mono-2.2/mono/Makefile.am 2008-12-10 15:38:37.000000000 -0500
+@@ -1,3 +1,3 @@
+
+-SUBDIRS = utils io-layer monoburg os cil metadata \
++SUBDIRS = utils io-layer os cil metadata \
+ arch interpreter mini dis monograph tests benchmark profiler
+Index: mono-2.2/mono/mini/Makefile.am
+===================================================================
+--- mono-2.2.orig/mono/mini/Makefile.am 2008-12-10 15:44:11.000000000 -0500
++++ mono-2.2/mono/mini/Makefile.am 2008-12-10 15:44:22.000000000 -0500
+@@ -482,7 +482,7 @@
+ $(GENMDESC_PRG) $(srcdir)/cpu-mips.md cpu-mips.h mips_desc
+
+ inssel.c inssel.h: $(BURGSRC)
+- $(monodir)/mono/monoburg/monoburg -c 1 -p -e $(BURGSRC) -d inssel.h -s inssel.c
++ monoburg -c 1 -p -e $(BURGSRC) -d inssel.h -s inssel.c
+
+ testi: mono test.exe
+ $(RUNTIME) -v -v --ncompile 1 --compile Test:$(mtest) test.exe