summaryrefslogtreecommitdiff
path: root/packages/mono/mono-1.9.1+2.2-rc1
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2009-01-07 12:19:00 -0500
committerCliff Brake <cbrake@bec-systems.com>2009-01-07 13:54:02 -0500
commitc929ffc653fbb29f0666674ac0412446221cea9a (patch)
tree0ffa39ebec6fca02a7c9eb1332c533a403cd4bb7 /packages/mono/mono-1.9.1+2.2-rc1
parentca084dba42b886690cf227c4ccf2326432fe6c93 (diff)
mono 2.2: update from preview 3 to RC1, add EABI patch
This changeset renames recipes to better reflect mono versioning. Note, the previous mono 2.2 recipe was mis-named rc2 and was actually preview 2. If you built the misnamed 2.2.0-rc2 package, it will take precedence over the new recipe and you must manually remove ipks in the tmp dir before building the 2.2-rc1 version.
Diffstat (limited to 'packages/mono/mono-1.9.1+2.2-rc1')
-rw-r--r--packages/mono/mono-1.9.1+2.2-rc1/configure.patch44
-rw-r--r--packages/mono/mono-1.9.1+2.2-rc1/disable-docs.patch13
-rw-r--r--packages/mono/mono-1.9.1+2.2-rc1/disable-monoburg.patch22
-rw-r--r--packages/mono/mono-1.9.1+2.2-rc1/fix-eabi-syscall.patch12
4 files changed, 91 insertions, 0 deletions
diff --git a/packages/mono/mono-1.9.1+2.2-rc1/configure.patch b/packages/mono/mono-1.9.1+2.2-rc1/configure.patch
new file mode 100644
index 0000000000..689f7be5da
--- /dev/null
+++ b/packages/mono/mono-1.9.1+2.2-rc1/configure.patch
@@ -0,0 +1,44 @@
+Index: mono-2.2/configure.in
+===================================================================
+--- mono-2.2.orig/configure.in 2008-11-13 18:22:29.000000000 -0500
++++ mono-2.2/configure.in 2008-12-10 16:03:11.000000000 -0500
+@@ -1155,6 +1155,8 @@
+ ], [
+ AC_MSG_RESULT(no)
+ with_tls=pthread
++ ], [
++ AC_MSG_RESULT(yes)
+ ])
+ fi
+
+@@ -1257,6 +1259,9 @@
+ ], [
+ with_sigaltstack=no
+ AC_MSG_RESULT(no)
++ ], [
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_WORKING_SIGALTSTACK)
+ ])
+ fi
+
+@@ -1746,6 +1751,7 @@
+
+ jit_wanted=false
+ interp_wanted=false
++echo "CLIFF: checking host = $host"
+ case "$host" in
+ # mips-sgi-irix5.* | mips-sgi-irix6.*)
+ # TARGET=MIPS;
+@@ -1882,10 +1888,12 @@
+ jit_wanted=true
+ ;;
+ arm*-linux*)
++ echo "CLIFF: found arm linux"
+ TARGET=ARM;
+ arch_target=arm;
+ ACCESS_UNALIGNED="no"
+ JIT_SUPPORTED=yes
++ CPPFLAGS="$CPPFLAGS -DARM_FPU_VFP=1"
+ jit_wanted=true
+ ;;
+ s390-*-linux*)
diff --git a/packages/mono/mono-1.9.1+2.2-rc1/disable-docs.patch b/packages/mono/mono-1.9.1+2.2-rc1/disable-docs.patch
new file mode 100644
index 0000000000..2c1812e1a5
--- /dev/null
+++ b/packages/mono/mono-1.9.1+2.2-rc1/disable-docs.patch
@@ -0,0 +1,13 @@
+Index: mono-2.2/Makefile.am
+===================================================================
+--- mono-2.2.orig/Makefile.am 2008-12-10 16:25:14.000000000 -0500
++++ mono-2.2/Makefile.am 2008-12-10 16:25:24.000000000 -0500
+@@ -1,7 +1,7 @@
+ AUTOMAKE_OPTIONS = foreign
+ ACLOCAL_AMFLAGS = -I .
+
+-SUBDIRS = po $(libgc_dir) $(eglib_dir) mono $(ikvm_native_dir) support data runtime scripts man samples web msvc docs
++SUBDIRS = po $(libgc_dir) $(eglib_dir) mono $(ikvm_native_dir) support data runtime scripts man samples web msvc
+
+ # Keep in sync with SUBDIRS
+ ## 'tools' is not normally built
diff --git a/packages/mono/mono-1.9.1+2.2-rc1/disable-monoburg.patch b/packages/mono/mono-1.9.1+2.2-rc1/disable-monoburg.patch
new file mode 100644
index 0000000000..14a2a094a7
--- /dev/null
+++ b/packages/mono/mono-1.9.1+2.2-rc1/disable-monoburg.patch
@@ -0,0 +1,22 @@
+Index: mono-2.2/mono/Makefile.am
+===================================================================
+--- mono-2.2.orig/mono/Makefile.am 2008-12-10 15:38:30.000000000 -0500
++++ mono-2.2/mono/Makefile.am 2008-12-10 15:38:37.000000000 -0500
+@@ -1,3 +1,3 @@
+
+-SUBDIRS = utils io-layer monoburg os cil metadata \
++SUBDIRS = utils io-layer os cil metadata \
+ arch interpreter mini dis monograph tests benchmark profiler
+Index: mono-2.2/mono/mini/Makefile.am
+===================================================================
+--- mono-2.2.orig/mono/mini/Makefile.am 2008-12-10 15:44:11.000000000 -0500
++++ mono-2.2/mono/mini/Makefile.am 2008-12-10 15:44:22.000000000 -0500
+@@ -482,7 +482,7 @@
+ $(GENMDESC_PRG) $(srcdir)/cpu-mips.md cpu-mips.h mips_desc
+
+ inssel.c inssel.h: $(BURGSRC)
+- $(monodir)/mono/monoburg/monoburg -c 1 -p -e $(BURGSRC) -d inssel.h -s inssel.c
++ monoburg -c 1 -p -e $(BURGSRC) -d inssel.h -s inssel.c
+
+ testi: mono test.exe
+ $(RUNTIME) -v -v --ncompile 1 --compile Test:$(mtest) test.exe
diff --git a/packages/mono/mono-1.9.1+2.2-rc1/fix-eabi-syscall.patch b/packages/mono/mono-1.9.1+2.2-rc1/fix-eabi-syscall.patch
new file mode 100644
index 0000000000..b752a8bd14
--- /dev/null
+++ b/packages/mono/mono-1.9.1+2.2-rc1/fix-eabi-syscall.patch
@@ -0,0 +1,12 @@
+--- mono.orig/mono/mini/mini-arm.c 2008/12/12 19:49:41 121457
++++ mono/mono/mini/mini-arm.c 2009/01/05 08:58:47 122416
+@@ -581,6 +581,8 @@
+ {
+ #if __APPLE__
+ sys_icache_invalidate (code, size);
++#elif ((__GNUC__ >= 4) && (__GNUC_MINOR__ >= 1))
++ __clear_cache (code, code + size);
+ #else
+ __asm __volatile ("mov r0, %0\n"
+ "mov r1, %1\n"
+