summaryrefslogtreecommitdiff
path: root/packages/mono/mono-1.2.5/configure.patch
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-09-06 10:41:59 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-09-06 10:41:59 +0000
commit8460c2fecbe36ce06135d64b683b0f2c3d924baf (patch)
tree31168741ed50561ea536a335b5bfb6b3007771ef /packages/mono/mono-1.2.5/configure.patch
parent325f26749da469ef7d90430a1be7b6f1e9d014a8 (diff)
parent56b356eeb9cbb597e7271068f5b0708b4a7844be (diff)
merge of '471f6e7d5fb5bc4d13a2338851dabca9f72b3f0a'
and '89b1d1f0f032b64f7620006be8bcf6271c70f4b8'
Diffstat (limited to 'packages/mono/mono-1.2.5/configure.patch')
-rw-r--r--packages/mono/mono-1.2.5/configure.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/packages/mono/mono-1.2.5/configure.patch b/packages/mono/mono-1.2.5/configure.patch
new file mode 100644
index 0000000000..1553115c0e
--- /dev/null
+++ b/packages/mono/mono-1.2.5/configure.patch
@@ -0,0 +1,67 @@
+Index: mono-1.2.5/configure.in
+===================================================================
+--- mono-1.2.5.orig/configure.in
++++ mono-1.2.5/configure.in
+@@ -1134,6 +1134,8 @@ if test x$platform_win32 = xno; then
+ ], [
+ AC_MSG_RESULT(no)
+ with_tls=pthread
++ ], [
++ AC_MSG_RESULT(yes)
+ ])
+ fi
+
+@@ -1236,6 +1238,9 @@ if test x$platform_win32 = xno; then
+ ], [
+ with_sigaltstack=no
+ AC_MSG_RESULT(no)
++ ], [
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_WORKING_SIGALTSTACK)
+ ])
+ fi
+
+@@ -1893,24 +1898,26 @@ if test "x$with_tls" = "x__thread"; then
+ ])
+ fi
+
+-if test ${TARGET} = ARM; then
+- dnl ******************************************
+- dnl *** Check to see what FPU is available ***
+- dnl ******************************************
+- AC_MSG_CHECKING(which FPU to use)
+-
+- AC_TRY_COMPILE([], [
+- __asm__ ("ldfd f0, [r0]");
+- ], fpu=FPA, [
+- AC_TRY_COMPILE([], [
+- __asm__ ("fldd d0, [r0]");
+- ], fpu=VFP, fpu=NONE)
+- ])
++#if test ${TARGET} = ARM; then
++# dnl ******************************************
++# dnl *** Check to see what FPU is available ***
++# dnl ******************************************
++# AC_MSG_CHECKING(which FPU to use)
++#
++# AC_TRY_COMPILE([], [
++# __asm__ ("ldfd f0, [r0]");
++# ], fpu=FPA, [
++# AC_TRY_COMPILE([], [
++# __asm__ ("fldd d0, [r0]");
++# ], fpu=VFP, fpu=NONE)
++# ])
++#
++# AC_MSG_RESULT($fpu)
++# CPPFLAGS="$CPPFLAGS -DARM_FPU_$fpu=1"
++# unset fpu
++#fi
+
+- AC_MSG_RESULT($fpu)
+- CPPFLAGS="$CPPFLAGS -DARM_FPU_$fpu=1"
+- unset fpu
+-fi
++ CPPFLAGS="$CPPFLAGS -DARM_FPU_NONE=1"
+
+ if test ${TARGET} = unknown; then
+ CPPFLAGS="$CPPFLAGS -DNO_PORT"