summaryrefslogtreecommitdiff
path: root/packages/mono/mono-1.2.5.1
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-03-11 18:12:03 +0000
committerJohn Lee <john_lee@openmoko.org>2008-03-11 18:12:03 +0000
commit6fcdf85424191d742baf654a02e3337d03ee8815 (patch)
tree849944501efcecb556116dbf251033544d4e57b7 /packages/mono/mono-1.2.5.1
parent7a97c29072572bf147bf625b80982441c11b7c01 (diff)
mono: use monoburg from mono-native instead
* the original method is to build monoburg natively during the (crossed) mono build. it will require glib-dev from host. now we use the one from mono-native. * mono-native 1.2.5.1 is updated to stage monoburg
Diffstat (limited to 'packages/mono/mono-1.2.5.1')
-rw-r--r--packages/mono/mono-1.2.5.1/disable-monoburg.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/mono/mono-1.2.5.1/disable-monoburg.patch b/packages/mono/mono-1.2.5.1/disable-monoburg.patch
new file mode 100644
index 0000000000..21c1e30f07
--- /dev/null
+++ b/packages/mono/mono-1.2.5.1/disable-monoburg.patch
@@ -0,0 +1,22 @@
+Index: mono-1.2.5.1/mono/Makefile.am
+===================================================================
+--- mono-1.2.5.1.orig/mono/Makefile.am 2008-03-05 15:52:06.000000000 +0800
++++ mono-1.2.5.1/mono/Makefile.am 2008-03-05 15:52:23.000000000 +0800
+@@ -1,3 +1,3 @@
+
+-SUBDIRS = utils io-layer monoburg os cil metadata \
++SUBDIRS = utils io-layer os cil metadata \
+ arch interpreter mini dis monograph tests benchmark profiler
+Index: mono-1.2.5.1/mono/mini/Makefile.am
+===================================================================
+--- mono-1.2.5.1.orig/mono/mini/Makefile.am 2008-03-05 16:02:51.000000000 +0800
++++ mono-1.2.5.1/mono/mini/Makefile.am 2008-03-05 16:02:57.000000000 +0800
+@@ -436,7 +436,7 @@
+ $(GENMDESC_PRG) $(srcdir)/cpu-mips.md cpu-mips.h mips_desc
+
+ inssel.c inssel.h: $(BURGSRC)
+- $(monodir)/mono/monoburg/monoburg -c 1 -p -e $(BURGSRC) -d inssel.h -s inssel.c
++ monoburg -c 1 -p -e $(BURGSRC) -d inssel.h -s inssel.c
+
+ testi: mono test.exe
+ $(RUNTIME) -v -v --ncompile 1 --compile Test:$(mtest) test.exe