summaryrefslogtreecommitdiff
path: root/packages/mono/mono-1.2.5.1/configure.patch
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-10-05 12:43:03 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-10-05 12:43:03 +0000
commitfb5a8ff3d88fca827e22ad48f136c7fe1c6cea10 (patch)
treef28b9b4a860576cf9909d567efc7baeb20dd2740 /packages/mono/mono-1.2.5.1/configure.patch
parentf0f72d8aa5de6a41796117c6e781e150bbacbe47 (diff)
parentbab0c48ac5132ad63b4f3da27a1c39c20b5db86c (diff)
merge of 'aac60b186b977130a688c4d00bfde913fb6221eb'
and 'f42403739ba7106ebfe92b3af59bf9c81b54f06d'
Diffstat (limited to 'packages/mono/mono-1.2.5.1/configure.patch')
-rw-r--r--packages/mono/mono-1.2.5.1/configure.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/packages/mono/mono-1.2.5.1/configure.patch b/packages/mono/mono-1.2.5.1/configure.patch
new file mode 100644
index 0000000000..1553115c0e
--- /dev/null
+++ b/packages/mono/mono-1.2.5.1/configure.patch
@@ -0,0 +1,67 @@
+Index: mono-1.2.5/configure.in
+===================================================================
+--- mono-1.2.5.orig/configure.in
++++ mono-1.2.5/configure.in
+@@ -1134,6 +1134,8 @@ if test x$platform_win32 = xno; then
+ ], [
+ AC_MSG_RESULT(no)
+ with_tls=pthread
++ ], [
++ AC_MSG_RESULT(yes)
+ ])
+ fi
+
+@@ -1236,6 +1238,9 @@ if test x$platform_win32 = xno; then
+ ], [
+ with_sigaltstack=no
+ AC_MSG_RESULT(no)
++ ], [
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_WORKING_SIGALTSTACK)
+ ])
+ fi
+
+@@ -1893,24 +1898,26 @@ if test "x$with_tls" = "x__thread"; then
+ ])
+ fi
+
+-if test ${TARGET} = ARM; then
+- dnl ******************************************
+- dnl *** Check to see what FPU is available ***
+- dnl ******************************************
+- AC_MSG_CHECKING(which FPU to use)
+-
+- AC_TRY_COMPILE([], [
+- __asm__ ("ldfd f0, [r0]");
+- ], fpu=FPA, [
+- AC_TRY_COMPILE([], [
+- __asm__ ("fldd d0, [r0]");
+- ], fpu=VFP, fpu=NONE)
+- ])
++#if test ${TARGET} = ARM; then
++# dnl ******************************************
++# dnl *** Check to see what FPU is available ***
++# dnl ******************************************
++# AC_MSG_CHECKING(which FPU to use)
++#
++# AC_TRY_COMPILE([], [
++# __asm__ ("ldfd f0, [r0]");
++# ], fpu=FPA, [
++# AC_TRY_COMPILE([], [
++# __asm__ ("fldd d0, [r0]");
++# ], fpu=VFP, fpu=NONE)
++# ])
++#
++# AC_MSG_RESULT($fpu)
++# CPPFLAGS="$CPPFLAGS -DARM_FPU_$fpu=1"
++# unset fpu
++#fi
+
+- AC_MSG_RESULT($fpu)
+- CPPFLAGS="$CPPFLAGS -DARM_FPU_$fpu=1"
+- unset fpu
+-fi
++ CPPFLAGS="$CPPFLAGS -DARM_FPU_NONE=1"
+
+ if test ${TARGET} = unknown; then
+ CPPFLAGS="$CPPFLAGS -DNO_PORT"