summaryrefslogtreecommitdiff
path: root/packages/mml-widget/gtkmathview_0.8.0.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
commit12f8a39939c28003a39b84713d9a51305511650d (patch)
tree2235c3d2a30eac66c0319b7cff55928990c89bbd /packages/mml-widget/gtkmathview_0.8.0.bb
parent058132b8be45ac2041a574782b8800c1956e44d3 (diff)
parentfcbe107913b10643d1ba8ac137de273e12e8854a (diff)
merge of '470ca3fe64c9411d3a7d992db39d5efbed869839'
and '912f388483a3e1703ca89d7b2309723fd3407420'
Diffstat (limited to 'packages/mml-widget/gtkmathview_0.8.0.bb')
-rw-r--r--packages/mml-widget/gtkmathview_0.8.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/mml-widget/gtkmathview_0.8.0.bb b/packages/mml-widget/gtkmathview_0.8.0.bb
new file mode 100644
index 0000000000..2fe48ea872
--- /dev/null
+++ b/packages/mml-widget/gtkmathview_0.8.0.bb
@@ -0,0 +1,24 @@
+LICENSE = "GPL"
+HOMEPAGE = "http://helm.cs.unibo.it/mml-widget/"
+DEPENDS = "t1lib gtk+ popt libxslt libxml2"
+
+SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \
+ file://mathview-gcc43x.diff;patch=1 \
+ "
+
+inherit autotools
+AUTOTOOLS_STAGE_PKGCONFIG = 1
+
+EXTRA_OECONF = "--disable-binreloc"
+
+do_configure_prepend() {
+ sed -i -e s:AM_BINRELOC::g ${S}/configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+ for i in ${PKG_CONFIG_DIR}/*math*.pc ; do
+ sed -i -e s:${STAGING_INCDIR}:'${libdir}':g $i
+ done
+}
+