summaryrefslogtreecommitdiff
path: root/packages/minipredict/dictionary_en-GB.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/minipredict/dictionary_en-GB.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/minipredict/dictionary_en-GB.bb')
-rw-r--r--packages/minipredict/dictionary_en-GB.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/minipredict/dictionary_en-GB.bb b/packages/minipredict/dictionary_en-GB.bb
index e69de29bb2..223ab23f20 100644
--- a/packages/minipredict/dictionary_en-GB.bb
+++ b/packages/minipredict/dictionary_en-GB.bb
@@ -0,0 +1,25 @@
+inherit update-alternatives
+
+DESCRIPTION = "Dictionary file for libdictionary"
+DEPENDS = "zip-native perl-native"
+SECTION = "gpe"
+PRIORITY = "optional"
+
+SRC_URI = "http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/dictionaries/en_GB.zip"
+
+ALTERNATIVE_NAME = "dictionary"
+ALTERNATIVE_LINK = "${datadir}/dictionary/dictionary"
+ALTERNATIVE_PATH = "${datadir}/dictionary/en_GB"
+ALTERNATIVE_PRIORITY = "50"
+
+do_compile() {
+ perl -ne ' s,/.*,,; next if ( /[.1-9]/ || /^.{0,1}$/ ); print;' ${WORKDIR}/en_GB.dic | sort > en_GB
+}
+
+FILES_${PN} = "${datadir}/dictionary"
+
+do_install() {
+ install -d ${D}/${datadir}/dictionary
+ install ${S}/en_GB ${D}/${datadir}/dictionary/
+}
+