summaryrefslogtreecommitdiff
path: root/packages/midpath/midpath-native_svn.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2007-08-08 21:15:31 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2007-08-08 21:15:31 +0000
commitd9e16f02594b391b5e04f960b38e19d48f564d08 (patch)
treea6baf51cf828c2c71df43c6a20802913c288307b /packages/midpath/midpath-native_svn.bb
parentfe54cefe6eb9875b1c7db019bd3528d4398fbebc (diff)
midpath: inital support for midpath
* puts java-cldc1.1 support in oe * split in servals packages, because more than one native UI is support * its support for now qte, qt3x11, x11 and awt * there is more work to do for integrate more modules like bluetooth, sdl or pluseaudio * upstream will start to switch to autotools
Diffstat (limited to 'packages/midpath/midpath-native_svn.bb')
-rw-r--r--packages/midpath/midpath-native_svn.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/midpath/midpath-native_svn.bb b/packages/midpath/midpath-native_svn.bb
new file mode 100644
index 0000000000..199facdeb1
--- /dev/null
+++ b/packages/midpath/midpath-native_svn.bb
@@ -0,0 +1,34 @@
+
+inherit native
+
+require midpath_${PV}.bb
+
+DEPENDS = "ecj-native fastjar-native classpath-minimal-native"
+PROVIDES = "virtual/cldc-api-1.1"
+
+PACKAGES = " "
+
+
+do_configure() {
+ :
+}
+
+do_compile() {
+mkdir -p ${S}/dist
+
+# Build CLDC1.1
+# Build base classes
+cd ${S}/external/cldc1.1/src
+make JAVAC=${JAVAC_CMD} JAVAC_FLAGS="-bootclasspath . -source 1.3 -target 1.1" || exit 1
+make install JAVAC=${JAVAC_CMD} JAVAC_FLAGS="-bootclasspath . -source 1.3 -target 1.1" CLASS_DIR=${S}/external/cldc1.1/classes || exit 1
+# Build CLDC extra classes for MIDP2
+cd ${S}/src/cldc-glue
+make JAVAC=${JAVAC_CMD} JAVAC_FLAGS="-bootclasspath ${S}/external/cldc1.1/classes -sourcepath ${S}/src/cldc-glue -source 1.3 -target 1.1"
+make install JAVAC=${JAVAC_CMD} JAVAC_FLAGS="-bootclasspath ${S}/external/cldc1.1/classes -source 1.3 -target 1.1" CLASS_DIR=${S}/external/cldc1.1/classes
+# Make a jar
+fastjar cvf ${S}/dist/cldc1.1.jar -C ${S}/external/cldc1.1/classes .
+}
+
+do_install() {
+ :
+}