summaryrefslogtreecommitdiff
path: root/packages/midpath/midpath-demos_0.2+0.3rc1.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-06-27 01:01:29 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-06-27 01:01:29 +0000
commitff39b335b0bd4eea36282479718035ccca72f9d4 (patch)
tree4ca39c7600af79d32484cc192afd13f305210bef /packages/midpath/midpath-demos_0.2+0.3rc1.bb
parent112f0a4352b46a805c466ffebd664cfc9f64872d (diff)
Removal of midpath 0.1, addition of midpath 0.3 rc1
midpath-alsa 0.1: Removed. midpath-cldc-native 0.1: Removed. midpath-cldc-sdl 0.1: Removed. midpath-cldc-x11 0.1: Removed. midpath-cldc 0.1: Removed. midpath-gtk 0.1: Removed. midpath-pulseaudio 0.1: Removed. midpath-qt3x11 0.1: Removed. midpath-qte 0.1: Removed. midpath-test 0.1: Removed. midpath 0.1: Removed. midpath-backend-alsa 0.2+0.3rc1: New recipe. midpath-backend-escher 0.2+0.3rc1: New recipe. midpath-backend-esd 0.2+0.3rc1: New recipe. midpath-backend-fb 0.2+0.3rc1: New recipe. midpath-backend-gtk 0.2+0.3rc1: New recipe. midpath-backend-gtk-hildon 0.2+0.3rc1: New recipe. midpath-backend-pulseaudio 0.2+0.3rc1: New recipe. midpath-backend-qt3x11 0.2+0.3rc1: New recipe. midpath-backend-qt4x11 0.2+0.3rc1: New recipe. midpath-backend-qte 0.2+0.3rc1: New recipe. midpath-backend-sdl 0.2+0.3rc1: New recipe. midpath-cldc 0.2+0.3rc1: New recipe. midpath-core 0.2+0.3rc1: New recipe. midpath-demos 0.2+0.3rc1: New recipe. midpath-jgl 0.2+0.3rc1: New recipe. midpath-location 0.2+0.3rc1: New recipe. midpath-m3g 0.2+0.3rc1: New recipe. midpath-maemo 0.2+0.3rc1: New recipe. midpath-messaging 0.2+0.3rc1: New recipe. midpath-opengles 0.2+0.3rc1: New recipe. midpath-openmoko 0.2+0.3rc1: New recipe. midpath-svg 0.2+0.3rc1: New recipe. midpath-webservices 0.2+0.3rc1: New recipe.
Diffstat (limited to 'packages/midpath/midpath-demos_0.2+0.3rc1.bb')
-rw-r--r--packages/midpath/midpath-demos_0.2+0.3rc1.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/packages/midpath/midpath-demos_0.2+0.3rc1.bb b/packages/midpath/midpath-demos_0.2+0.3rc1.bb
new file mode 100644
index 0000000000..1a2f690bf1
--- /dev/null
+++ b/packages/midpath/midpath-demos_0.2+0.3rc1.bb
@@ -0,0 +1,53 @@
+require midpath-common.inc
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc1.tar.gz"
+
+S = "${WORKDIR}/midpath-0.3rc1"
+
+DEPENDS = "midpath-core midpath-location midpath-messaging midpath-svg midpath-opengles midpath-m3g"
+RDEPENDS = "midpath midpath-location midpath-messaging midpath-svg-midp midpath-opengles midpath-m3g"
+
+DESCRIPTION = "Demonstration programs of the MIDPath library"
+
+JAR = "midpath-demos.jar"
+
+do_compile() {
+ # Only Demos enabled.
+ midpath_build \
+ --disable-midpath \
+ --disable-cldc \
+ --disable-sdljava-cldc \
+ --disable-escher-cldc \
+ --disable-jlayerme-cldc \
+ --disable-jorbis-cldc \
+ --disable-avetanabt-cldc \
+ --disable-jgl-cldc \
+ --disable-web_services-api \
+ --disable-messaging-api \
+ --disable-svg-api \
+ --disable-opengl-api \
+ --disable-m3g-api \
+ --with-location-jar=${STAGING_DATADIR}/midpath/jsr179-location.jar \
+ --with-messaging-jar=${STAGING_DATADIR}/midpath/jsr205-messaging.jar \
+ --with-svg-core-jar=${STAGING_DATADIR}/midpath/jsr226-svg-core.jar \
+ --with-opengles-core-jar=${STAGING_DATADIR}/midpath/jsr239-opengles-core.jar \
+ --with-opengles-nio-jar=${STAGING_DATADIR}/midpath/jsr239-opengles-nio.jar \
+ --with-m3g-jar=${STAGING_DATADIR}/midpath/jsr184-m3g.jar \
+ --with-avetanabt-cldc-jar=${STAGING_DATADIR}/midpath/avetanabt-cldc.jar
+}
+
+do_install() {
+ install -d ${D}${datadir}/midpath/repository
+ install -m 0644 dist/${JAR} ${D}${datadir}/midpath/repository
+}
+
+do_stage() {
+ install -d ${STAGING_DATADIR}/midpath/repository
+ install -m 0644 dist/${JAR} ${STAGING_DATADIR}/midpath/repository
+}
+
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${datadir}/midpath/repository/${JAR}"