summaryrefslogtreecommitdiff
path: root/packages/meta
diff options
context:
space:
mode:
authorDavid Karlstrom <daka@thg.se>2005-08-03 07:29:11 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-03 07:29:11 +0000
commit97e9c3d88d439b8c43683345320f02b35ec4be36 (patch)
tree4093fda17198e95ba7a00b37f1b6e6ac68218775 /packages/meta
parentbdedcb2aefea95ea9b1bbf87ed63348455605c88 (diff)
parent2e021572c0f09ee5e23d67c1110226b4998e7171 (diff)
merge of 0241e7bd233c727dc013a20bd6cbfadd4a2a04dc
and 9b92b607ea4961e9ebb9ee801dfb76e3bf258ed4
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/openslug-packages.bb60
-rw-r--r--packages/meta/ucslugc-packages.bb131
2 files changed, 155 insertions, 36 deletions
diff --git a/packages/meta/openslug-packages.bb b/packages/meta/openslug-packages.bb
index 7e248bc60e..1e53d342d2 100644
--- a/packages/meta/openslug-packages.bb
+++ b/packages/meta/openslug-packages.bb
@@ -34,24 +34,20 @@ OPENSLUG_DEVELOPMENT = "\
openssh \
patch \
pciutils \
+ perl \
pkgconfig \
quilt \
sed \
strace \
- util-linux \
- "
-
-# These packages only build on TARGET_OS=linux, not
-# TARGET_OS=linux-uclibc
-OPENSLUG_DEVELOPMENT_append_linux = "\
- perl \
tar \
+ util-linux \
"
OPENSLUG_PACKAGES = "\
atftp \
bash \
+ bind \
bluez-utils-nodbus \
bridge-utils \
bwmon \
@@ -60,6 +56,7 @@ OPENSLUG_PACKAGES = "\
cron \
cvs\
cyrus-imapd \
+ db4 \
dnsmasq \
expat \
ftpd-topfield \
@@ -67,61 +64,52 @@ OPENSLUG_PACKAGES = "\
gphoto2 \
gtk-doc \
less \
+ libpam \
libusb \
libxml2 \
+ man man-pages \
+ mgetty \
miau \
microcom \
+ mpd \
mt-daapd \
mutt \
mysql \
nail \
nano \
ncftp \
+ nfs-utils \
+ ntp \
obexftp openobex openobex-apps ircp \
+ openldap \
+ openntpd \
openssh \
openvpn \
pcre \
+ php \
+ postfix \
ppp \
procps \
+ psmisc \
puppy \
pwc \
+ python \
+ reiserfsprogs reiser4progs \
rsync \
+ samba \
+ sane-backends \
+ screen \
setpwc \
+ strace \
+ streamripper \
sudo \
sysfsutils \
thttpd \
- db4 \
- openldap \
- openntpd \
- ntp \
- reiserfsprogs reiser4progs \
- python \
- samba \
- sane-backends \
- strace \
thttpd \
+ timezones \
+ unionfs-modules unionfs-utils \
vlan \
wget \
- unionfs-modules unionfs-utils \
- "
-
-# These packages only build on TARGET_OS=linux, not
-# TARGET_OS=linux-uclibc (Note that for several this
-# is because of use of single precision FP interfaces
-# such as sinf.)
-OPENSLUG_PACKAGES_append_linux = "\
- bind \
- man man-pages \
- mgetty \
- mpd \
- nfs-utils \
- libpam \
- php \
- postfix \
- psmisc \
- screen \
- streamripper \
- timezones \
xinetd \
yp-tools ypbind ypserv \
"
diff --git a/packages/meta/ucslugc-packages.bb b/packages/meta/ucslugc-packages.bb
new file mode 100644
index 0000000000..afd029bc30
--- /dev/null
+++ b/packages/meta/ucslugc-packages.bb
@@ -0,0 +1,131 @@
+# Meta package containing all the packages which build for UcSlugC
+#
+# All packages in here must build with the ucslugc.conf distro, they
+# do not necessarily work.
+DESCRIPTION = "Packages that are compatible with the UcSlugC firmware"
+LICENSE = MIT
+PR = "r0"
+
+INHIBIT_DEFAULT_DEPS = "1"
+ALLOW_EMPTY = 1
+PACKAGES = "${PN}"
+
+# The list of packages to build for the ucslugc DISTRO.
+# KEEP IN ALPHABETICAL ORDER
+UCSLUGC_PACKAGES = "\
+ atftp \
+ autoconf \
+ automake \
+ bash \
+ bash \
+ binutils \
+ bison \
+ bluez-utils-nodbus \
+ bridge-utils \
+ bwmon \
+ bzip2 \
+ ccxstream \
+ coreutils \
+ coreutils \
+ cron \
+ cvs \
+ cvs\
+ cyrus-imapd \
+ db4 \
+ diffutils \
+ dnsmasq \
+ expat \
+ findutils \
+ flex \
+ ftpd-topfield \
+ gawk \
+ gcc \
+ gdb \
+ glib-2.0 \
+ gnu-config \
+ gphoto2 \
+ grep \
+ gtk-doc \
+ gzip \
+ ipkg-utils \
+ less \
+ libtool \
+ libusb \
+ libxml2 \
+ lsof \
+ m4 \
+ make \
+ miau \
+ microcom \
+ monotone-4 monotone-5 \
+ mt-daapd \
+ mutt \
+ mysql \
+ nail \
+ nano \
+ ncftp \
+ ncurses \
+ ntp \
+ obexftp openobex openobex-apps ircp \
+ openldap \
+ openntpd \
+ openssh \
+ openssh \
+ openvpn \
+ patch \
+ pciutils \
+ pcre \
+ pkgconfig \
+ ppp \
+ procps \
+ puppy \
+ pwc \
+ python \
+ quilt \
+ reiserfsprogs reiser4progs \
+ rsync \
+ samba \
+ sane-backends \
+ sed \
+ setpwc \
+ strace \
+ strace \
+ sudo \
+ sysfsutils \
+ thttpd \
+ thttpd \
+ unionfs-modules unionfs-utils \
+ util-linux \
+ vlan \
+ wget \
+ "
+
+# These packages only build on TARGET_OS=linux, but not TARGET_OS=linux-uclibc.
+# KEEP IN ALPHABETICAL ORDER
+UCSLUGC_BROKEN_PACKAGES = "\
+ bind \
+ libpam \
+ man man-pages \
+ mgetty \
+ mpd \
+ perl \
+ php \
+ postfix \
+ psmisc \
+ screen \
+ streamripper \
+ tar \
+ timezones \
+ xinetd \
+ "
+
+# These packages will never build because uclibc lacks (and always will lack)
+# appropriate support. This define is for documentation of this fact!
+UCSLUGC_UNSUPPORTABLE_PACKAGES = "\
+ nfs-utils \
+ yp-tools ypbind ypserv \
+ "
+
+# The package-index at the end causes regeneration of the Packages.gz and
+# other control files.
+DEPENDS = "openslug-image ${UCSLUGC_PACKAGES} package-index"