summaryrefslogtreecommitdiff
path: root/packages/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2007-12-01 18:17:51 +0000
committerRichard Purdie <rpurdie@rpsys.net>2007-12-01 18:17:51 +0000
commit964f34b7eedb789cbd55441195cf739756662766 (patch)
tree959db77e041012fa5398b0dd101af2444af5a2d3 /packages/meta
parent46c11035838a5bcf4b50385ebd549828be84a73e (diff)
meta-toolchain: Add a note about the libgcc package problems and factor out a variable name (from poky)
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/meta-toolchain.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/packages/meta/meta-toolchain.bb b/packages/meta/meta-toolchain.bb
index 92fded00af..991d079fcd 100644
--- a/packages/meta/meta-toolchain.bb
+++ b/packages/meta/meta-toolchain.bb
@@ -70,10 +70,11 @@ do_populate_sdk() {
mkdir -p ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/shlibs/
for pkg in $target_pkgs ; do
for arch in $revipkgarchs; do
- if [ -e ${DEPLOY_DIR_IPK}/$arch/${pkg}_*_$arch.ipk ]; then
- echo "Found ${DEPLOY_DIR_IPK}/$arch/${pkg}_$arch.ipk"
- cp ${DEPLOY_DIR_IPK}/$arch/${pkg}_*_$arch.ipk ${SDK_OUTPUT}/${prefix}/ipk/
- orig_pkg=`ipkg-list-fields ${DEPLOY_DIR_IPK}/$arch/${pkg}_*_$arch.ipk | grep OE: | cut -d ' ' -f2`
+ pkgnames=${DEPLOY_DIR_IPK}/$arch/${pkg}_*_$arch.ipk
+ if [ -e $pkgnames ]; then
+ echo "Found $pkgnames"
+ cp $pkgnames ${SDK_OUTPUT}/${prefix}/ipk/
+ orig_pkg=`ipkg-list-fields $pkgnames | grep OE: | cut -d ' ' -f2`
pkg_subdir=$arch${TARGET_VENDOR}${@['-' + bb.data.getVar('TARGET_OS', d, 1), ''][bb.data.getVar('TARGET_OS', d, 1) == ('' or 'custom')]}
mkdir -p ${SDK_OUTPUT}/${prefix}/pkgdata/$pkg_subdir/runtime
cp ${STAGING_DIR}/pkgdata/$pkg_subdir/$orig_pkg ${SDK_OUTPUT}/${prefix}/pkgdata/$pkg_subdir/
@@ -97,6 +98,8 @@ do_populate_sdk() {
# add missing link to libgcc_s.so.1
# libgcc-dev should be responsible for that, but it's not getting built
+ # RP: it gets smashed up depending on the order that gcc, gcc-cross and
+ # gcc-cross-sdk get built :( (30/11/07)
ln -sf libgcc_s.so.1 ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/lib/libgcc_s.so
# remove unwanted executables