summaryrefslogtreecommitdiff
path: root/packages/meta
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-12-23 00:23:57 +0000
committerHolger Freyther <zecke@selfish.org>2007-12-23 00:23:57 +0000
commit6e715d8f2561a8fac492cc10528102608c64eb74 (patch)
treee862647ff900034f08bfc6d1f7920d858bc63451 /packages/meta
parenta31bd35ef6affae2aa03832b261a19803ff4ed77 (diff)
Remove some GNUism and replace cp -a with cp -pPR (once again)
I didn't touch the to be installed files, as we have GNU coreutils or at least a compatible busybox version on our targets so far.
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/external-toolchain.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/packages/meta/external-toolchain.bb b/packages/meta/external-toolchain.bb
index c483ea26a6..47d9a93a15 100644
--- a/packages/meta/external-toolchain.bb
+++ b/packages/meta/external-toolchain.bb
@@ -30,21 +30,21 @@ do_stage() {
install -d ${STAGING_DIR}/pkgdata/
install -d ${STAGING_DIR_TARGET}/shlibs/
- cp -ar ${prefix}/pkgdata/* ${STAGING_DIR}/pkgdata/
- cp -ar ${prefix}/${TARGET_SYS}/shlibs/* ${STAGING_DIR_TARGET}/shlibs/
+ cp -pPRr ${prefix}/pkgdata/* ${STAGING_DIR}/pkgdata/
+ cp -pPRr ${prefix}/${TARGET_SYS}/shlibs/* ${STAGING_DIR_TARGET}/shlibs/
if [ -d ${prefix}/ipk ]; then
install -d ${DEPLOY_DIR_IPK}/
- cp -ar ${prefix}/ipk/* ${DEPLOY_DIR_IPK}/
+ cp -pPRr ${prefix}/ipk/* ${DEPLOY_DIR_IPK}/
fi
if [ -d ${prefix}/deb ]; then
install -d ${DEPLOY_DIR_DEB}/
- cp -ar ${prefix}/deb/* ${DEPLOY_DIR_DEB}/
+ cp -pPRr ${prefix}/deb/* ${DEPLOY_DIR_DEB}/
fi
if [ -d ${prefix}/pstage -a "x${DEPLOY_DIR_PSTAGE}" != "x" ]; then
install -d ${DEPLOY_DIR_PSTAGE}/
- cp -ar ${prefix}/pstage/* ${DEPLOY_DIR_PSTAGE}/
+ cp -pPRr ${prefix}/pstage/* ${DEPLOY_DIR_PSTAGE}/
fi
}