summaryrefslogtreecommitdiff
path: root/packages/meta
diff options
context:
space:
mode:
authorccsmart <ccsmart@smartpal.de>2005-08-04 17:26:04 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-04 17:26:04 +0000
commit194e9823419ad76b29d14edb3733c18009fe3311 (patch)
treef5cfd383da8db66b1ac1e0740fd17d81c632e328 /packages/meta
parent5b511e5e7d437f2b897511c7d70232f1e60b5510 (diff)
parent319f88ac01cb5cb3ec90a088705e16c30c686d06 (diff)
merge of 8691e90bbf4e4ab0587f1abc3e0a4bb9bcdf53df
and c579a3af7687e512137c2653f94a4b14ce3b4d4f
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/openslug-native-packages.bb19
-rw-r--r--packages/meta/openslug-native.bb8
-rw-r--r--packages/meta/openslug-packages.bb67
-rw-r--r--packages/meta/ucslugc-packages.bb132
4 files changed, 188 insertions, 38 deletions
diff --git a/packages/meta/openslug-native-packages.bb b/packages/meta/openslug-native-packages.bb
new file mode 100644
index 0000000000..8a32b9cb70
--- /dev/null
+++ b/packages/meta/openslug-native-packages.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Packages that are to be compiled nativly for the OpenSlug firmware"
+LICENSE = MIT
+PR = "r2"
+
+INHIBIT_DEFAULT_DEPS = "1"
+ALLOW_EMPTY = 1
+PACKAGES = "${PN}"
+
+# Just something the test with
+OPENSLUG_NATIVE_PACKAGES = "\
+ gzip \
+ vlan \
+ "
+
+BROKEN_PACKAGES = "\
+ "
+
+DEPENDS = '${OPENSLUG_NATIVE_PACKAGES} \
+ package-index'
diff --git a/packages/meta/openslug-native.bb b/packages/meta/openslug-native.bb
index bb5a68d01e..b52d2ef6eb 100644
--- a/packages/meta/openslug-native.bb
+++ b/packages/meta/openslug-native.bb
@@ -1,12 +1,13 @@
DESCRIPTION = "Packages that are required for the OpenSlug native build environment"
LICENSE = MIT
-PR = "r7"
+PR = "r10"
INHIBIT_DEFAULT_DEPS = "1"
ALLOW_EMPTY = 1
PACKAGES = "${PN}"
OPENSLUG_NATIVE = "\
+ autoconf \
automake \
bash \
binutils binutils-dev binutils-symlinks \
@@ -29,6 +30,7 @@ OPENSLUG_NATIVE = "\
libreadline4 libreadline-dev \
libstdc++-dev \
libthread-db1 \
+ libtool \
lrzsz \
m4 \
make \
@@ -36,7 +38,9 @@ OPENSLUG_NATIVE = "\
ncurses ncurses-dev ncurses-terminfo \
patch \
perl perl-modules \
- python-core python-io python-lang python-pickle python-shell python-textutils \
+ pkgconfig \
+ python-core python-crypt python-io python-lang python-pickle python-shell python-textutils \
+ quilt \
sed \
tar \
util-linux \
diff --git a/packages/meta/openslug-packages.bb b/packages/meta/openslug-packages.bb
index 7e248bc60e..6d16f9039d 100644
--- a/packages/meta/openslug-packages.bb
+++ b/packages/meta/openslug-packages.bb
@@ -34,24 +34,20 @@ OPENSLUG_DEVELOPMENT = "\
openssh \
patch \
pciutils \
+ perl \
pkgconfig \
quilt \
sed \
strace \
- util-linux \
- "
-
-# These packages only build on TARGET_OS=linux, not
-# TARGET_OS=linux-uclibc
-OPENSLUG_DEVELOPMENT_append_linux = "\
- perl \
tar \
+ util-linux \
"
OPENSLUG_PACKAGES = "\
atftp \
bash \
+ bind \
bluez-utils-nodbus \
bridge-utils \
bwmon \
@@ -60,70 +56,69 @@ OPENSLUG_PACKAGES = "\
cron \
cvs\
cyrus-imapd \
+ db4 \
dnsmasq \
expat \
ftpd-topfield \
glib-2.0 \
gphoto2 \
gtk-doc \
+ iperf \
+ jpeg \
less \
+ libpam \
+ libpng \
libusb \
libxml2 \
+ man man-pages \
+ mgetty \
miau \
microcom \
+ mpd \
mt-daapd \
mutt \
mysql \
nail \
nano \
ncftp \
+ netpbm \
+ nfs-utils \
+ ntp \
obexftp openobex openobex-apps ircp \
+ openldap \
+ openntpd \
openssh \
openvpn \
pcre \
+ php \
+ postfix \
ppp \
procps \
+ psmisc \
puppy \
pwc \
+ python \
+ reiserfsprogs reiser4progs \
rsync \
+ samba \
+ sane-backends \
+ screen \
setpwc \
+ strace \
+ streamripper \
sudo \
sysfsutils \
thttpd \
- db4 \
- openldap \
- openntpd \
- ntp \
- reiserfsprogs reiser4progs \
- python \
- samba \
- sane-backends \
- strace \
thttpd \
+ tiff \
+ timezones \
+ unionfs-modules unionfs-utils \
vlan \
+ wakelan \
wget \
- unionfs-modules unionfs-utils \
- "
-
-# These packages only build on TARGET_OS=linux, not
-# TARGET_OS=linux-uclibc (Note that for several this
-# is because of use of single precision FP interfaces
-# such as sinf.)
-OPENSLUG_PACKAGES_append_linux = "\
- bind \
- man man-pages \
- mgetty \
- mpd \
- nfs-utils \
- libpam \
- php \
- postfix \
- psmisc \
- screen \
- streamripper \
- timezones \
xinetd \
yp-tools ypbind ypserv \
+ zlib \
"
BROKEN_PACKAGES = "\
diff --git a/packages/meta/ucslugc-packages.bb b/packages/meta/ucslugc-packages.bb
new file mode 100644
index 0000000000..7074cfff48
--- /dev/null
+++ b/packages/meta/ucslugc-packages.bb
@@ -0,0 +1,132 @@
+# Meta package containing all the packages which build for UcSlugC
+#
+# All packages in here must build with the ucslugc.conf distro, they
+# do not necessarily work.
+DESCRIPTION = "Packages that are compatible with the UcSlugC firmware"
+LICENSE = MIT
+PR = "r0"
+
+INHIBIT_DEFAULT_DEPS = "1"
+ALLOW_EMPTY = 1
+PACKAGES = "${PN}"
+
+# The list of packages to build for the ucslugc DISTRO.
+# KEEP IN ALPHABETICAL ORDER
+UCSLUGC_PACKAGES = "\
+ atftp \
+ autoconf \
+ automake \
+ bash \
+ binutils \
+ bison \
+ bluez-utils-nodbus \
+ bridge-utils \
+ bwmon \
+ bzip2 \
+ ccxstream \
+ coreutils \
+ cron \
+ cvs \
+ cvs\
+ cyrus-imapd \
+ db4 \
+ diffutils \
+ dnsmasq \
+ expat \
+ findutils \
+ flex \
+ ftpd-topfield \
+ gawk \
+ gcc \
+ gdb \
+ glib-2.0 \
+ gnu-config \
+ gphoto2 \
+ grep \
+ gtk-doc \
+ gzip \
+ ipkg-utils \
+ jpeg \
+ less \
+ libpng \
+ libtool \
+ libusb \
+ libxml2 \
+ lsof \
+ m4 \
+ make \
+ miau \
+ microcom \
+ monotone-4 monotone-5 \
+ mpd \
+ mt-daapd \
+ mutt \
+ mysql \
+ nail \
+ nano \
+ ncftp \
+ ncurses \
+ netpbm \
+ ntp \
+ obexftp openobex openobex-apps ircp \
+ openldap \
+ openntpd \
+ openssh \
+ openvpn \
+ patch \
+ pciutils \
+ pcre \
+ perl \
+ pkgconfig \
+ ppp \
+ procps \
+ puppy \
+ pwc \
+ python \
+ quilt \
+ reiserfsprogs reiser4progs \
+ rsync \
+ samba \
+ sane-backends \
+ sed \
+ setpwc \
+ strace \
+ streamripper \
+ sudo \
+ sysfsutils \
+ thttpd \
+ tiff \
+ unionfs-modules unionfs-utils \
+ util-linux \
+ vlan \
+ wakelan \
+ wget \
+ zlib \
+ "
+
+# These packages only build on TARGET_OS=linux, but not TARGET_OS=linux-uclibc.
+# KEEP IN ALPHABETICAL ORDER
+UCSLUGC_BROKEN_PACKAGES = "\
+ bind \
+ libpam \
+ man man-pages \
+ mgetty \
+ php \
+ postfix \
+ psmisc \
+ screen \
+ tar \
+ timezones \
+ xinetd \
+ "
+
+# These packages will never build because uclibc lacks (and always will lack)
+# appropriate support. This define is for documentation of this fact!
+UCSLUGC_UNSUPPORTABLE_PACKAGES = "\
+ nfs-utils \
+ yp-tools ypbind ypserv \
+ "
+
+# The package-index at the end causes regeneration of the Packages.gz and
+# other control files.
+DEPENDS = "openslug-image ${UCSLUGC_PACKAGES} package-index"