summaryrefslogtreecommitdiff
path: root/packages/meta
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/meta
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/meta-sdk.bb4
-rw-r--r--packages/meta/task-bootstrap-unionroot.bb4
-rw-r--r--packages/meta/task-bootstrap.bb4
-rw-r--r--packages/meta/unslung-standard-image.bb2
4 files changed, 11 insertions, 3 deletions
diff --git a/packages/meta/meta-sdk.bb b/packages/meta/meta-sdk.bb
index dd15eacb1c..757c72ecb3 100644
--- a/packages/meta/meta-sdk.bb
+++ b/packages/meta/meta-sdk.bb
@@ -148,8 +148,8 @@ EOF
echo 'GROUP ( libpthread.so.0 libpthread_nonshared.a )' > ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/lib/libpthread.so
echo 'GROUP ( libc.so.6 libc_nonshared.a )' > ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/lib/libc.so
# remove unwanted housekeeping files
- mv ${SDK_OUTPUT}/usr/lib/ipkg/status ${SDK_OUTPUT}/${prefix}/package-status
- rm -rf ${SDK_OUTPUT}/usr/lib/ipkg
+ mv ${SDK_OUTPUT}${libdir}/ipkg/status ${SDK_OUTPUT}/${prefix}/package-status
+ rm -rf ${SDK_OUTPUT}${libdir}/ipkg
# remove unwanted executables
rm -rf ${SDK_OUTPUT}/${prefix}/sbin ${SDK_OUTPUT}/${prefix}/etc
diff --git a/packages/meta/task-bootstrap-unionroot.bb b/packages/meta/task-bootstrap-unionroot.bb
index 2226d8251c..8435388174 100644
--- a/packages/meta/task-bootstrap-unionroot.bb
+++ b/packages/meta/task-bootstrap-unionroot.bb
@@ -35,10 +35,13 @@ def bootstrap_modutils_rdepends(d):
r.append('module-init-tools-depmod')
return ' '.join(r)
+HOTPLUG ?= "linux-hotplug"
+
DEPENDS = 'base-files base-passwd-3.5.7 \
busybox dropbear initscripts modutils netbase \
sysvinit tinylogin portmap \
modutils-initscripts \
+ ${HOTPLUG} \
${BOOTSTRAP_EXTRA_DEPENDS} \
${@bootstrap_modutils_depends(d)} \
unionfs-modules \
@@ -50,6 +53,7 @@ RDEPENDS = 'base-files base-passwd busybox \
initscripts \
netbase sysvinit sysvinit-pidof tinylogin \
modutils-initscripts \
+ ${HOTPLUG} \
${BOOTSTRAP_EXTRA_RDEPENDS} \
${@bootstrap_modutils_rdepends(d)} \
unionfs-modules \
diff --git a/packages/meta/task-bootstrap.bb b/packages/meta/task-bootstrap.bb
index 00074b679d..ccd57b8661 100644
--- a/packages/meta/task-bootstrap.bb
+++ b/packages/meta/task-bootstrap.bb
@@ -31,10 +31,13 @@ def bootstrap_modutils_rdepends(d):
r.append('module-init-tools-depmod')
return ' '.join(r)
+HOTPLUG ?= "linux-hotplug"
+
DEPENDS = 'base-files base-passwd-3.5.7 \
busybox dropbear initscripts modutils netbase \
sysvinit tinylogin portmap \
modutils-initscripts \
+ ${HOTPLUG} \
${BOOTSTRAP_EXTRA_DEPENDS} \
${@bootstrap_modutils_depends(d)}'
@@ -42,6 +45,7 @@ RDEPENDS = 'base-files base-passwd busybox \
initscripts \
netbase sysvinit sysvinit-pidof tinylogin \
modutils-initscripts \
+ ${HOTPLUG} \
${BOOTSTRAP_EXTRA_RDEPENDS} \
${@bootstrap_modutils_rdepends(d)}'
diff --git a/packages/meta/unslung-standard-image.bb b/packages/meta/unslung-standard-image.bb
index 413a51037f..ae2bfd44fb 100644
--- a/packages/meta/unslung-standard-image.bb
+++ b/packages/meta/unslung-standard-image.bb
@@ -27,7 +27,7 @@ inherit image_ipk
# Note that anything in this function must be repeatable without having to rebuild the rootfs
unslung_clean_image () {
# Remove info from the local feed used to build the image
- rm -f ${IMAGE_ROOTFS}/usr/lib/ipkg/lists/*
+ rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/lists/*
rm -f ${IMAGE_ROOTFS}/${sysconfdir}/version
}