summaryrefslogtreecommitdiff
path: root/packages/meta
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-06 20:31:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-06 20:31:36 +0000
commit412469753744572609eebca9636f69a0f9683d33 (patch)
tree9ece03d3852ee46dc63ccbf139930d7918fbb2c5 /packages/meta
parenteeb51b853fc1c0ee24f3643cdd66d936fe36c291 (diff)
ucslugc-packages: add ucslugc-native, alsa-lib, alsa-utils
ucslugc-native has the uclibc dependencies to ensure that installing the native package gives everything required for debugging on ucslugc.
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/ucslugc-native.bb81
-rw-r--r--packages/meta/ucslugc-packages.bb4
2 files changed, 84 insertions, 1 deletions
diff --git a/packages/meta/ucslugc-native.bb b/packages/meta/ucslugc-native.bb
new file mode 100644
index 0000000000..1300b95f30
--- /dev/null
+++ b/packages/meta/ucslugc-native.bb
@@ -0,0 +1,81 @@
+DESCRIPTION = "Packages that are required for the UcSlugC native build environment"
+LICENSE = MIT
+PR = "r0"
+
+INHIBIT_DEFAULT_DEPS = "1"
+ALLOW_EMPTY = 1
+PACKAGES = "${PN}"
+
+# Run-time only (RDEPENDS) stuff - no package explicitly provides
+# these targets.
+UCSLUGC_NATIVE_RT_prepend_linux = "\
+ glibc-utils \
+ libc6-dev \
+ "
+UCSLUGC_NATIVE_RT_prepend_linux-uclibc = "\
+ uclibc-dev uclibc-utils \
+ "
+UCSLUGC_NATIVE_RT = "\
+ binutils-dev binutils-symlinks \
+ cpp cpp-symlinks \
+ g++ g++-symlinks \
+ gcc-symlinks \
+ libg2c-dev \
+ libgdbm3 \
+ libperl5 \
+ libreadline4 libreadline-dev \
+ libstdc++-dev \
+ libthread-db1 \
+ ncurses-dev ncurses-terminfo \
+ perl-modules \
+ python-crypt python-io python-lang python-pickle python-shell python-textutils \
+ "
+
+# Run-time and DEPENDS
+UCSLUGC_NATIVE_prepend_linux = "\
+ glibc-extra-nss \
+ libc6 \
+ "
+UCSLUGC_NATIVE_prepend_linux-uclibc = "\
+ libiconv \
+ uclibc \
+ "
+UCSLUGC_NATIVE = "\
+ autoconf \
+ automake \
+ bash \
+ binutils \
+ bison \
+ bzip2 \
+ coreutils \
+ cvs \
+ diffstat \
+ flex \
+ gawk \
+ gcc \
+ gnu-config \
+ gzip \
+ libtool \
+ lrzsz \
+ m4 \
+ make \
+ monotone-5 \
+ ncurses \
+ patch \
+ perl \
+ pkgconfig \
+ python-core \
+ quilt \
+ sed \
+ tar \
+ util-linux \
+ wget \
+ "
+
+# These things are required but are not valid RDEPENDS
+UCSLUGC_NATIVE_DP = "\
+ gdbm \
+ "
+
+RDEPENDS = '${UCSLUGC_NATIVE_RT} ${UCSLUGC_NATIVE}'
+DEPENDS = '${UCSLUGC_NATIVE_DP} ${UCSLUGC_NATIVE}'
diff --git a/packages/meta/ucslugc-packages.bb b/packages/meta/ucslugc-packages.bb
index 44eb82cf58..55fc193037 100644
--- a/packages/meta/ucslugc-packages.bb
+++ b/packages/meta/ucslugc-packages.bb
@@ -13,6 +13,8 @@ PACKAGES = "${PN}"
# The list of packages to build for the ucslugc DISTRO.
# KEEP IN ALPHABETICAL ORDER
UCSLUGC_PACKAGES = "\
+ alsa-lib \
+ alsa-utils \
atftp \
audiofile \
autoconf \
@@ -153,4 +155,4 @@ UCSLUGC_UNSUPPORTABLE_PACKAGES = "\
# The package-index at the end causes regeneration of the Packages.gz and
# other control files.
-DEPENDS = "openslug-image ${UCSLUGC_PACKAGES} openslug-native package-index"
+DEPENDS = "openslug-image ${UCSLUGC_PACKAGES} ucslugc-native package-index"