summaryrefslogtreecommitdiff
path: root/packages/meta/task-bootstrap.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-01-08 13:51:39 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-08 13:51:39 +0000
commit0500b5f01143f6eafb8fbacc061bbe245283caee (patch)
treeb76c2697d1628d4453606022d33e9d6a384fc54e /packages/meta/task-bootstrap.bb
parentb2d178844371bb2d413eb6aed1e83a89783d7d96 (diff)
DEPENDS cleanup of packages/meta. This doesn't fix all DEPENDS here but does remove a large chunk of the incorrect ones. Some entries that shouldn't be present have been marked FIXME as they indicate problems elsewhere in the metadata. Help from the opie/gpe gurus needed. I've not touched the NSLU code as I suspect they'd rather do this themselves?
Diffstat (limited to 'packages/meta/task-bootstrap.bb')
-rw-r--r--packages/meta/task-bootstrap.bb18
1 files changed, 0 insertions, 18 deletions
diff --git a/packages/meta/task-bootstrap.bb b/packages/meta/task-bootstrap.bb
index 31920135d4..ef76ec4345 100644
--- a/packages/meta/task-bootstrap.bb
+++ b/packages/meta/task-bootstrap.bb
@@ -11,16 +11,6 @@ PACKAGES = "${PN}"
MODUTILS ?= "24 26"
-def bootstrap_modutils_depends(d):
- import bb
- m = bb.data.getVar('MODUTILS', d, 1)
- r = []
- if '24' in m:
- r.append('modutils')
- if '26' in m:
- r.append('module-init-tools')
- return ' '.join(r)
-
def bootstrap_modutils_rdepends(d):
import bb
m = bb.data.getVar('MODUTILS', d, 1)
@@ -33,14 +23,6 @@ def bootstrap_modutils_rdepends(d):
HOTPLUG ?= "linux-hotplug"
-DEPENDS = 'base-files base-passwd-3.5.9 \
- busybox dropbear initscripts modutils netbase \
- sysvinit tinylogin portmap psmisc setserial\
- modutils-initscripts \
- ${HOTPLUG} \
- ${BOOTSTRAP_EXTRA_DEPENDS} \
- ${@bootstrap_modutils_depends(d)}'
-
RDEPENDS = 'base-files base-passwd busybox \
initscripts \
netbase sysvinit sysvinit-pidof tinylogin \