summaryrefslogtreecommitdiff
path: root/packages/meta/slugos-imagename.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-13 00:12:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-13 00:12:55 +0000
commitd924093f081ced9752c93839dfd3c649c47c751a (patch)
treeb2906681c33b4e83e95c689a8abe4d96991d5b7c /packages/meta/slugos-imagename.bb
parentc6008f022c47d36f3fa1d899eafecb7e15a162cf (diff)
slugos-imagename: added to ensure distro-specific images still build in slugos-imagename.bb
Diffstat (limited to 'packages/meta/slugos-imagename.bb')
-rw-r--r--packages/meta/slugos-imagename.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/meta/slugos-imagename.bb b/packages/meta/slugos-imagename.bb
new file mode 100644
index 0000000000..dfca396c7c
--- /dev/null
+++ b/packages/meta/slugos-imagename.bb
@@ -0,0 +1,33 @@
+# This is an inglorious hack to provide a package to match
+# ${SLUGOS_IMAGENAME}-image
+MAINTAINER = "John Bowler <jbowler@acm.org>
+PN = "${SLUGOS_IMAGENAME}-image"
+PV = "0"
+PR = "r0"
+DEPENDS = "slugos-image"
+PACKAGES = ""
+INHIBIT_DEFAULT_DEPS = "1"
+
+do_fetch() {
+}
+do_unpack() {
+}
+do_patch() {
+}
+do_configure() {
+}
+do_compile() {
+}
+do_install() {
+}
+do_stage() {
+}
+do_build() {
+}
+
+python () {
+ # Don't build slugos images unless the configuration is set up
+ # for an image build!
+ if bb.data.getVar("SLUGOS_IMAGENAME", d, 1) == '':
+ raise bb.parse.SkipPackage("absent SlugOS configuration")
+}