summaryrefslogtreecommitdiff
path: root/packages/meta/openslug-image.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-11 07:18:34 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-11 07:18:34 +0000
commitdbd1a76089b2b95b9c57fff7dd7d22c67a93a4e3 (patch)
tree7234291c163f9422814908cff50e2f24f5c6f2ca /packages/meta/openslug-image.bb
parent47bb3895991dd77781dee8274159b032ebbc6b31 (diff)
openslug, ucslugc: convert to use slugos.conf
- All the openslug/ucslugc specific .bb files are converted in this - change to use generic 'slugos' files with the required configuration - in openslug.conf or ucslugc.conf. This unifies the image and package - build stuff. Old targets should continue to work as the slugos - .bb files PROVIDE the required targets.
Diffstat (limited to 'packages/meta/openslug-image.bb')
-rw-r--r--packages/meta/openslug-image.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/packages/meta/openslug-image.bb b/packages/meta/openslug-image.bb
deleted file mode 100644
index 63ee2cc204..0000000000
--- a/packages/meta/openslug-image.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-# This describes a generic NSLU2 image, even though the bb file is
-# called 'openslug-image.bb' the OpenSlug specific configuration is
-# done in conf/distro/openslug.conf
-#
-PR = "r15"
-
-IMAGE_BASENAME = "openslug"
-
-IMAGE_LINGUAS = ""
-# Setting USE_DEVFS prevents *any* entries being created initially
-# in /dev
-USE_DEVFS = "1"
-
-# diff, cpio and find are required for reflash and turnup ram.
-# Removing these probably leaves the system bootable, but standard
-# openslug and ucslugc stuff won't work, so only take these out in
-# very non-standard turnkey ucslugc builds.
-#
-# udev is the default way of handling devices, there is no guarantee
-# that the static device table is completely correct (it is just
-# known to be sufficient for boot.)
-OPENSLUG_SUPPORT ?= "diffutils cpio findutils udev"
-
-# NOTE: file system kernel modules are defined in openslug.conf
-# (OPENSLUG_EXTRA_FILESYSTEMS, included in OPENSLUG_EXTRA_INSTALL)
-# kernel-module-af-packet must be in the image for DHCP to work
-OPENSLUG_KERNEL ?= "kernel-module-af-packet kernel-module-netconsole"
-
-# The things explicitly included in the following lists are the
-# absolute minimum to have any chance of a bootable system.
-DEPENDS = "virtual/kernel base-files base-passwd \
- busybox dropbear hotplug-ng initscripts-openslug netbase \
- sysvinit tinylogin portmap \
- virtual/ixp-eth openslug-init \
- module-init-tools modutils-initscripts \
- ipkg-collateral ipkg ipkg-link \
- ${OPENSLUG_SUPPORT} \
- ${OPENSLUG_EXTRA_DEPENDS}"
-
-IPKG_INSTALL = "base-files base-passwd \
- busybox dropbear hotplug-ng initscripts-openslug netbase \
- update-modules sysvinit tinylogin portmap \
- ${PREFERRED_PROVIDER_virtual/ixp-eth} openslug-init \
- module-init-tools modutils-initscripts \
- ipkg-collateral ipkg ipkg-link \
- ${OPENSLUG_SUPPORT} \
- ${OPENSLUG_KERNEL} \
- ${OPENSLUG_EXTRA_INSTALL}"
-
-inherit image_ipk
-
-python () {
- # Don't build openslug images unless we're targeting an nslu2 or nas100d
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'nslu2' and mach != 'nas100d':
- raise bb.parse.SkipPackage("OpenSlug only builds for the Linksys NSLU2")
-}
-LICENSE = MIT