summaryrefslogtreecommitdiff
path: root/packages/meta/meta-opie-dynamic.bb
diff options
context:
space:
mode:
authorGreg Gilbert <greg@treke.net>2005-01-25 23:55:27 +0000
committerGreg Gilbert <greg@treke.net>2005-01-25 23:55:27 +0000
commit4b6dd819545d3643330d6adfd8fe7a4ac336a444 (patch)
treebb941d6333d60318b04f592cb9a5f5b2132e6dce /packages/meta/meta-opie-dynamic.bb
parent135edabb84e26ad8eaf959a45dc1e74c15cca6a5 (diff)
Many files:
All our meta packages are MIT BKrev: 41f6dc6frw9yS0pCfdpxU1TqUbO0YQ
Diffstat (limited to 'packages/meta/meta-opie-dynamic.bb')
-rw-r--r--packages/meta/meta-opie-dynamic.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/meta/meta-opie-dynamic.bb b/packages/meta/meta-opie-dynamic.bb
index e69de29bb2..0ee6a1f22a 100644
--- a/packages/meta/meta-opie-dynamic.bb
+++ b/packages/meta/meta-opie-dynamic.bb
@@ -0,0 +1,20 @@
+BROKEN = 1
+#
+# FIXME:
+# we need to get the necessary support from the OE infrastructure
+# to allow the dynamic package to work
+#
+DESCRIPTION = "Meta-package for Opie"
+DEPENDS = "qte-for-opie libqpe-opie libopie2 manufacturers"
+
+def opie_packages(d):
+ import bb, os
+ files = os.listdir( bb.data.getVar( "TOPDIR", d, True ) )
+ pkgs = [ f for f in files if f.startswith( "opie-" ) and f != "opie-3rdparty" ]
+ return " ".join( pkgs )
+
+OPIE_PACKAGES := "${@opie_packages(d)}"
+
+DEPENDS = "qte-for-opie libqpe-opie libopie2 ${OPIE_PACKAGES}"
+
+LICENSE = MIT