summaryrefslogtreecommitdiff
path: root/packages/matchbox-wm
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-08-08 09:21:26 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-08-08 09:21:26 +0000
commit1adf1c842a2e0ba55b4f01a9c12f0e3096bf0628 (patch)
tree07a76d417747ccb8ae2273a3ca35ffff463a59d2 /packages/matchbox-wm
parent8979ceed2e9ed94a2022a1c760bdec38e16e05d0 (diff)
parente1aa79108dc9335cee9aab3d0e5d60e8de473c46 (diff)
merge of '22a005b824014688c2c41c2dba34c42bf145a946'
and '8e90244a719ea0f6cc33218bf925484a5a4e1855'
Diffstat (limited to 'packages/matchbox-wm')
-rw-r--r--packages/matchbox-wm/matchbox-wm_1.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/matchbox-wm/matchbox-wm_1.1.bb b/packages/matchbox-wm/matchbox-wm_1.1.bb
new file mode 100644
index 0000000000..8e28d0c041
--- /dev/null
+++ b/packages/matchbox-wm/matchbox-wm_1.1.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+PR="r0"
+
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/1.1/matchbox-window-manager-${PV}.tar.gz \
+ file://kbdconfig"
+
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig update-alternatives
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
+
+do_install_prepend() {
+ install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
+}
+