summaryrefslogtreecommitdiff
path: root/packages/matchbox-wm/matchbox-wm_1.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-04-23 10:41:29 +0000
committerKoen Kooi <koen@openembedded.org>2007-04-23 10:41:29 +0000
commit30dbe7baba9a0101801b4db9101dbc69d5cb48e1 (patch)
tree8dafe081dc14c6f12ac4c889044c0201a522cc5e /packages/matchbox-wm/matchbox-wm_1.2.bb
parent99ad35ff9b91d5ca4e46267e54cd664ac3001f58 (diff)
matchbox-wm: add 1.2, merge in fixes from poky
Diffstat (limited to 'packages/matchbox-wm/matchbox-wm_1.2.bb')
-rw-r--r--packages/matchbox-wm/matchbox-wm_1.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/matchbox-wm/matchbox-wm_1.2.bb b/packages/matchbox-wm/matchbox-wm_1.2.bb
new file mode 100644
index 0000000000..a7e9d4df62
--- /dev/null
+++ b/packages/matchbox-wm/matchbox-wm_1.2.bb
@@ -0,0 +1,41 @@
+require matchbox-wm.inc
+
+DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+
+PR="r0"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/1.2/matchbox-window-manager-${PV}.tar.bz2 \
+ file://gconf-2.m4 \
+ file://kbdconfig"
+
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig update-alternatives
+
+FILES_${PN} = "${bindir}/* \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+EXTRA_OECONF = " \
+ --enable-startup-notification\
+ --enable-gconf \
+ --enable-expat \
+ --disable-xrm"
+
+do_configure_prepend () {
+ cp ${WORKDIR}/gconf-2.m4 ${S}/
+}
+
+do_install_prepend() {
+ install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
+}
+