summaryrefslogtreecommitdiff
path: root/packages/matchbox-sato
diff options
context:
space:
mode:
authorDaniel Willmann <daniel@totalueberwachung.de>2007-12-23 11:34:37 +0000
committerDaniel Willmann <daniel@totalueberwachung.de>2007-12-23 11:34:37 +0000
commit504661aa0fc08e8bd47a8409bb61f8e340ba6eaa (patch)
tree8db73da4fecb77a259fa3435495162ad509e136f /packages/matchbox-sato
parent787f243f097889a2abefcfd8a111bac420c3ed81 (diff)
parent20e5fbe217c05900868741ec16b09092eaf0830a (diff)
merge of '7b528e427242c4fc04839c0b8e3f065248b5c0dc'
and 'd8bfa63aa913e7227790ba2d02253cfbecce61ab'
Diffstat (limited to 'packages/matchbox-sato')
-rw-r--r--packages/matchbox-sato/.mtn2git_empty0
-rw-r--r--packages/matchbox-sato/matchbox-sato/.mtn2git_empty0
-rw-r--r--packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty0
-rw-r--r--packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty0
-rwxr-xr-xpackages/matchbox-sato/matchbox-sato/etc/matchbox/session15
-rw-r--r--packages/matchbox-sato/matchbox-sato/matchbox-session24
-rw-r--r--packages/matchbox-sato/matchbox-sato_0.1.bb29
7 files changed, 68 insertions, 0 deletions
diff --git a/packages/matchbox-sato/.mtn2git_empty b/packages/matchbox-sato/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/.mtn2git_empty b/packages/matchbox-sato/matchbox-sato/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty b/packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty b/packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/etc/matchbox/session b/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
new file mode 100755
index 0000000000..8c8f953b47
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+. /etc/formfactor/config
+
+if [ -e /dev/touchscreen/touchscreen0 ]; then
+ SHOWCURSOR="no"
+else
+ SHOWCURSOR="yes"
+fi
+
+matchbox-desktop &
+
+matchbox-panel --titlebar --start-applets showdesktop,windowselector --end-applets clock,battery,systray,startup &
+
+exec matchbox-window-manager -theme Sato -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
diff --git a/packages/matchbox-sato/matchbox-sato/matchbox-session b/packages/matchbox-sato/matchbox-sato/matchbox-session
new file mode 100644
index 0000000000..65f1ce72ca
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/matchbox-session
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Very simple session manager for matchbox tools
+#
+
+# Uncomment below to enable parsing of debian menu entrys
+# export MB_USE_DEB_MENUS=1
+
+if [ -e $HOME/.matchbox/session ]
+then
+exec $HOME/.matchbox/session
+fi
+
+if [ -e /etc/matchbox/session ]
+then
+exec /etc/matchbox/session
+fi
+
+# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
+# dont exist.
+
+matchbox-desktop &
+matchbox-panel --orientation south &
+exec matchbox-window-manager $@
diff --git a/packages/matchbox-sato/matchbox-sato_0.1.bb b/packages/matchbox-sato/matchbox-sato_0.1.bb
new file mode 100644
index 0000000000..b622f24586
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Custom MB session files for poky"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS = "gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato"
+RCONFLICTS = "matchbox-common"
+PR = "r17"
+
+SRC_URI = "file://etc file://matchbox-session"
+S = ${WORKDIR}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/matchbox-session ${D}/${bindir}
+ cp -R ${S}/etc ${D}/etc
+ rm -fR ${D}/etc/.svn
+ rm -fR ${D}/etc/matchbox/.svn
+ chmod -R 755 ${D}/etc
+}
+
+pkg_postinst_matchbox-sato () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 9"
+}