summaryrefslogtreecommitdiff
path: root/packages/matchbox-panel
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-02-17 20:01:03 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-17 20:01:03 +0000
commitcfc4141ec1ae0a8b5e109e876935bdc541b47d62 (patch)
tree0458efa4df0c8b11dd4027ca6fb2316c0cc3b143 /packages/matchbox-panel
parent917c32e14a416be6bf78d69554c21901a0cde732 (diff)
matchbox-panel: add patch to allow disabling the Utilities/Panel submenu which is hardcoded and redundant.
- tap-and-hold on the panel already allows adding applets - export MB_MENU_PANEL_DISABLED=1 before starting mb-applet-menu-launcher to disable the submenu
Diffstat (limited to 'packages/matchbox-panel')
-rw-r--r--packages/matchbox-panel/matchbox-panel-0.9.2/mb-panel-allow-disabling-menu-panel.patch33
-rw-r--r--packages/matchbox-panel/matchbox-panel_0.9.2.bb3
2 files changed, 35 insertions, 1 deletions
diff --git a/packages/matchbox-panel/matchbox-panel-0.9.2/mb-panel-allow-disabling-menu-panel.patch b/packages/matchbox-panel/matchbox-panel-0.9.2/mb-panel-allow-disabling-menu-panel.patch
new file mode 100644
index 0000000000..fb1a021c31
--- /dev/null
+++ b/packages/matchbox-panel/matchbox-panel-0.9.2/mb-panel-allow-disabling-menu-panel.patch
@@ -0,0 +1,33 @@
+--- matchbox-panel-0.9.2.multi/applets/mb-applet-menu-launcher.c 2006-02-16 00:43:28.000000000 +0100
++++ matchbox-panel-0.9.2/applets/mb-applet-menu-launcher.c 2006-02-17 20:25:14.000000000 +0100
+@@ -392,7 +392,8 @@
+ FILE *fp;
+ char *buf;
+ int len;
+- MBMenuMenu *menu_panel;
++ MBMenuMenu *menu_panel = NULL;
++ char *menu_panel_disabled = getenv ("MB_MENU_PANEL_DISABLED");
+ char *tmp_path = NULL, *tmp_path2 = NULL ;
+
+ char vfolder_path_root[512];
+@@ -453,8 +454,8 @@
+
+ }
+
+- menu_panel = mb_menu_add_path(app_data->mbmenu, "Utilities/Panel" , NULL, MBMENU_NO_SORT );
+-
++ if (!menu_panel_disabled)
++ menu_panel = mb_menu_add_path(app_data->mbmenu, "Utilities/Panel" , NULL, MBMENU_NO_SORT );
+
+ tmp_path = mb_dot_desktop_icon_get_full_path (app_data->theme_name,
+ 16,
+@@ -620,6 +621,9 @@
+ && !strcmp(mb_dotdesktop_get(dd, "Type"),
+ "PanelApp"))
+ {
++ if (menu_panel_disabled)
++ continue;
++
+ m = menu_panel;
+ }
+
diff --git a/packages/matchbox-panel/matchbox-panel_0.9.2.bb b/packages/matchbox-panel/matchbox-panel_0.9.2.bb
index 7ae8836040..8be2174daf 100644
--- a/packages/matchbox-panel/matchbox-panel_0.9.2.bb
+++ b/packages/matchbox-panel/matchbox-panel_0.9.2.bb
@@ -1,12 +1,13 @@
include matchbox-panel.inc
-PR="r11"
+PR="r12"
SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/0.9/${PN}-${PV}.tar.gz \
file://add_hostap.patch;patch=1 \
http://handhelds.org/~pb/mb-panel-0.9.2-polling.patch;patch=1 \
http://handhelds.org/~pb/mb-panel-0.9.2-msgcancel.patch;patch=1 \
file://mb-applet-battery-repaint.patch;patch=1 \
file://mb-panel-multi-category-matching.patch;patch=1 \
+ file://mb-panel-allow-disabling-menu-panel.patch;patch=1 \
file://system-monitor-crash-fix.patch;patch=1 "