summaryrefslogtreecommitdiff
path: root/packages/matchbox-applet-cards/matchbox-applet-cards_1.0.2.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2005-11-24 17:09:09 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-24 17:09:09 +0000
commit7bfbddb14c1a23b6981b4598f10ec2840779c4c0 (patch)
tree3d814f5b56640fe5cc4aada5ffbfe7e4b96741ed /packages/matchbox-applet-cards/matchbox-applet-cards_1.0.2.bb
parente92947233f868b0495ff2f19c5522f799f517f27 (diff)
matchbox-applet-cards: Add improved version of the pdaXrom card applet. A kind contribution by Patrick Steiner.
Diffstat (limited to 'packages/matchbox-applet-cards/matchbox-applet-cards_1.0.2.bb')
-rw-r--r--packages/matchbox-applet-cards/matchbox-applet-cards_1.0.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/matchbox-applet-cards/matchbox-applet-cards_1.0.2.bb b/packages/matchbox-applet-cards/matchbox-applet-cards_1.0.2.bb
new file mode 100644
index 0000000000..ca40ea572c
--- /dev/null
+++ b/packages/matchbox-applet-cards/matchbox-applet-cards_1.0.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Panel applet to eject cards (from PdaXrom project)"
+LICENSE = "GPL"
+DEPENDS = "matchbox-wm libmatchbox"
+SECTION = "x11/wm"
+PR = "r1"
+
+SRC_URI = "http://212.10.30.205/rc12/src/mb-applet-cards-${PV}.tar.bz2 \
+ file://oz-gpe.patch;patch=1 \
+ file://gpe-applet-cards \
+ file://cf_mount.png \
+ file://cf_unmount.png \
+ file://sd_mount.png \
+ file://sd_unmount.png \
+ file://cards.png"
+S = "${WORKDIR}/mb-applet-cards-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${bindir} ${datadir}/applications ${datadir}/pixmaps"
+
+do_install_append() {
+ install -m 0755 ${WORKDIR}/gpe-applet-cards ${D}${bindir}/gpe-applet-cards
+ install -m 0644 ${WORKDIR}/cf_mount.png ${D}${datadir}/pixmaps/cf_mount.png
+ install -m 0644 ${WORKDIR}/cf_unmount.png ${D}${datadir}/pixmaps/cf_unmount.png
+ install -m 0644 ${WORKDIR}/sd_mount.png ${D}${datadir}/pixmaps/sd_mount.png
+ install -m 0644 ${WORKDIR}/sd_unmount.png ${D}${datadir}/pixmaps/sd_unmount.png
+ install -m 0644 ${WORKDIR}/cards.png ${D}${datadir}/pixmaps/cards.png
+}