summaryrefslogtreecommitdiff
path: root/packages/masqmail/masqmail_0.2.21.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-12-18 13:50:04 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-12-18 13:50:04 +0000
commita29979e19ed76c2029cfd822951b7fde56a98a8e (patch)
tree85102cf43b72d5ce2294ab17f565183b4436729d /packages/masqmail/masqmail_0.2.21.bb
parent16b15891b993ca44dacd6c15ec678b2eac721548 (diff)
parent302f1878f6adacd506a24dd55fecc262a57bf61e (diff)
merge of '1d2340f5c0766711d217ca40fbfcb4cb196412ac'
and '8bee8c12a8f566036b80dc740f5215782a19eb8b'
Diffstat (limited to 'packages/masqmail/masqmail_0.2.21.bb')
-rw-r--r--packages/masqmail/masqmail_0.2.21.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/masqmail/masqmail_0.2.21.bb b/packages/masqmail/masqmail_0.2.21.bb
new file mode 100644
index 0000000000..05f377e4e5
--- /dev/null
+++ b/packages/masqmail/masqmail_0.2.21.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "MasqMail is a mail server designed for hosts that do not have \
+a permanent internet connection eg. a home network or a single host at home. \
+It has special support for connections to different ISPs. It replaces sendmail \
+or other MTAs such as qmail or exim."
+HOMEPAGE = "http://innominate.org/kurth/masqmail/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/m/${PN}/${PN}_${PV}.orig.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--disable-glibtest"
+EXTRA_OECONF += "--disable-resolver"
+
+# These are the standard Debian values for ownership of the programs,
+# this stuff fakes out the install script chown operations then replicates
+# them by setting the ipkg owner/group to the desired values - everything
+# ends up owned by the nominated user.
+MAIL_USER ?= "mail"
+MAIL_GROUP ?= "mail"
+
+EXTRA_OECONF += "--with-user=$(id -u)"
+EXTRA_OECONF += "--with-group=$(id -g)"
+
+IPKGBUILDCMD = "ipkg-build -o ${MAIL_USER} -g ${MAIL_GROUP}"