summaryrefslogtreecommitdiff
path: root/packages/maemo
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2005-07-09 07:50:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-09 07:50:17 +0000
commitf16b7c8f5bfe23e1341158bbb14f74235c36a45c (patch)
tree06c08534d3abbeb8d138ae3feb3c96de6ccd8fb7 /packages/maemo
parent68fa12aaeb722e79bf2f76a40a2079ff20d1ec1c (diff)
parent2b99b87f0289fa7abefd743bad0a23d4636c0479 (diff)
merge of 03133e2efc4b4ffe3f1544aca8171a7da90221f9
and 7c7ad63dfa7e9cf84ed42393167d84da1f7c2030
Diffstat (limited to 'packages/maemo')
-rw-r--r--packages/maemo/nokia770-init/fixup-770.sh8
-rw-r--r--packages/maemo/nokia770-init_1.0.bb9
2 files changed, 14 insertions, 3 deletions
diff --git a/packages/maemo/nokia770-init/fixup-770.sh b/packages/maemo/nokia770-init/fixup-770.sh
index 02c18d4108..b65fb131e3 100644
--- a/packages/maemo/nokia770-init/fixup-770.sh
+++ b/packages/maemo/nokia770-init/fixup-770.sh
@@ -4,6 +4,14 @@ case "$1" in
echo -n "Unmounting virtual fs from initrd"
umount /mnt/initfs/sys
umount /mnt/initfs/proc
+ ln -s /dev/vc/0 /dev/tty0
+ ln -s /dev/vc/1 /dev/tty1
+ ln -s /dev/vc/2 /dev/tty2
+ ln -s /dev/vc/3 /dev/tty3
+ ln -s /dev/vc/4 /dev/tty4
+ ln -s /dev/vc/5 /dev/tty5
+ ln -s /dev/vc/6 /dev/tty6
+ ln -s /dev/vc/7 /dev/tty7
;;
stop)
;;
diff --git a/packages/maemo/nokia770-init_1.0.bb b/packages/maemo/nokia770-init_1.0.bb
index 1cef924598..ab3333b438 100644
--- a/packages/maemo/nokia770-init_1.0.bb
+++ b/packages/maemo/nokia770-init_1.0.bb
@@ -1,6 +1,6 @@
LICENSE = "GPL"
MAINTAINER = "Florian Boor <florian@kernelconcepts.de"
-PR = "r1"
+PR = "r3"
DEPENDS = "base-passwd hotplug-dbus"
@@ -17,7 +17,7 @@ INITSCRIPT_PARAMS = "defaults 01"
do_install () {
install -d ${D}${sysconfdir}/init.d
- install -m 755 ${S}/fixup-770.sh ${D}/${sysconfdir}/init.d/fixup-770.sh
+ install -m 755 ${WORKDIR}/fixup-770.sh ${D}/${sysconfdir}/init.d/fixup-770.sh
install -d ${D}/lib/firmware
}
@@ -31,7 +31,10 @@ if [ "x$D" != "x" ]; then
fi
# set up some links to firmware and modules in initrd
- ln -sf /mnt/initfs/lib/firmware/* /lib/firmware/
+ mkdir -p /lib/firmware
+ ln -sf /mnt/initfs/usr/lib/hotplug/firmware/3825.arm /lib/firmware/3825.arm
+ ln -sf /mnt/initfs/usr/lib/hotplug/firmware/brf6150fw.bin /lib/firmware/brf6150fw.bin
+ ln -sf /mnt/initfs/usr/lib/hotplug/firmware/mtlm3825.arm /lib/firmware/mtlm3825.arm
rm -rf /lib/modules
ln -s /mnt/initfs/lib/modules /lib/modules