summaryrefslogtreecommitdiff
path: root/packages/maemo4
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-03-04 16:46:11 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-03-04 16:46:11 +0000
commitba69123b245d6244b756a07f7118bfb11acb47f0 (patch)
tree6c0f87cbb91fb142e9b748fdc2628e8390f5edd0 /packages/maemo4
parent25fe9599d951a3de39a2e8983810f2c6a40d74b0 (diff)
parentb1fbc8c1b11f8c30bf327b4605defac0a3d47457 (diff)
merge of '1d06736abd89e6b42d2eaf5918fcd17ad518fcb3'
and '3601bc2cdb1e980ccaf4f1de781d948df8d45545'
Diffstat (limited to 'packages/maemo4')
-rw-r--r--packages/maemo4/hildon-control-panel_2.0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/maemo4/hildon-control-panel_2.0.1.bb b/packages/maemo4/hildon-control-panel_2.0.1.bb
new file mode 100644
index 0000000000..d7dd6c3e90
--- /dev/null
+++ b/packages/maemo4/hildon-control-panel_2.0.1.bb
@@ -0,0 +1,20 @@
+LICENSE = "GPL"
+
+DEPENDS = "libosso libhildon gnome-vfs libhildonhelp"
+
+SRC_URI = "http://repository.maemo.org/pool/os2008/free/source/h/hildon-control-panel/hildon-control-panel_2.0.1-1.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/dbus-1.0 ${datadir}/applications"
+
+do_stage() {
+ autotools_stage_all
+}
+
+# pkg-config file will get broken after pkgconfig.bbclass work
+#
+# This code will fix it
+#
+# sed -i -e 's:${STAGING_LIBDIR}/hildon:${libdir}/hildon:g' -e 's:${STAGING_DATADIR}/applications/hildon:${datadir}/applications/hildon:g' ${PKG_CONFIG_DIR}/hildon-control-panel.pc
+#