summaryrefslogtreecommitdiff
path: root/packages/maemo4
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-03-07 12:40:47 +0000
committerJohn Lee <john_lee@openmoko.org>2008-03-07 12:40:47 +0000
commitb781aba534b1c5ba47a00fe9e2caaf8743536100 (patch)
tree2f6d5f780d0aeea2118ca212bb905d445313ee95 /packages/maemo4
parentbd4028cfd4a24a0c5875e7445bb115619830b947 (diff)
parente906546390539db91733531aa8007a59fcc3b60f (diff)
merge of '211b2bf7086145ba83e7b54cebded9bb3025b075'
and 'cb58be96e7128aa032b10e0b9d369ca6f59af487'
Diffstat (limited to 'packages/maemo4')
-rw-r--r--packages/maemo4/hildon-control-panel_2.0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/maemo4/hildon-control-panel_2.0.1.bb b/packages/maemo4/hildon-control-panel_2.0.1.bb
new file mode 100644
index 0000000000..d7dd6c3e90
--- /dev/null
+++ b/packages/maemo4/hildon-control-panel_2.0.1.bb
@@ -0,0 +1,20 @@
+LICENSE = "GPL"
+
+DEPENDS = "libosso libhildon gnome-vfs libhildonhelp"
+
+SRC_URI = "http://repository.maemo.org/pool/os2008/free/source/h/hildon-control-panel/hildon-control-panel_2.0.1-1.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/dbus-1.0 ${datadir}/applications"
+
+do_stage() {
+ autotools_stage_all
+}
+
+# pkg-config file will get broken after pkgconfig.bbclass work
+#
+# This code will fix it
+#
+# sed -i -e 's:${STAGING_LIBDIR}/hildon:${libdir}/hildon:g' -e 's:${STAGING_DATADIR}/applications/hildon:${datadir}/applications/hildon:g' ${PKG_CONFIG_DIR}/hildon-control-panel.pc
+#