summaryrefslogtreecommitdiff
path: root/packages/maemo/nokia770-init_1.0.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2005-07-04 21:25:25 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-04 21:25:25 +0000
commit4fefbe57202cc684e99dc408842f38906facc590 (patch)
treeec46d796bbd7fb4098b4780cad113399a4119bb1 /packages/maemo/nokia770-init_1.0.bb
parentb65e20b5cdf2db87453b03381894585460096192 (diff)
Add package to do some initialisation and fixups like unmounting stuff
from initrd and create some useful links.
Diffstat (limited to 'packages/maemo/nokia770-init_1.0.bb')
-rw-r--r--packages/maemo/nokia770-init_1.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/maemo/nokia770-init_1.0.bb b/packages/maemo/nokia770-init_1.0.bb
new file mode 100644
index 0000000000..1cef924598
--- /dev/null
+++ b/packages/maemo/nokia770-init_1.0.bb
@@ -0,0 +1,38 @@
+LICENSE = "GPL"
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de"
+PR = "r1"
+
+DEPENDS = "base-passwd hotplug-dbus"
+
+SRC_URI = "file://fixup-770.sh"
+
+FILES_${PN} = "${sysconfdir} ${libdir}"
+
+inherit update-rc.d
+
+
+INITSCRIPT_NAME = "fixup-770.sh"
+INITSCRIPT_PARAMS = "defaults 01"
+
+
+do_install () {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${S}/fixup-770.sh ${D}/${sysconfdir}/init.d/fixup-770.sh
+
+ install -d ${D}/lib/firmware
+}
+
+pkg_postinst () {
+#!/bin/sh
+
+# can't do adduser stuff offline
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+# set up some links to firmware and modules in initrd
+ ln -sf /mnt/initfs/lib/firmware/* /lib/firmware/
+
+ rm -rf /lib/modules
+ ln -s /mnt/initfs/lib/modules /lib/modules
+}