summaryrefslogtreecommitdiff
path: root/packages/madfu
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-04-04 11:58:54 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-04-04 11:58:54 +0000
commitf0f89d19f347b304800e730c69a7fbb86acb9b4b (patch)
tree86ccac7eba285705eba9f0fa5d5aef99b8e3b51b /packages/madfu
parent2c88fd5a4d4805d092618e4721d915a1578a6cdf (diff)
madfu: Clean up so it matches oe style guide
Diffstat (limited to 'packages/madfu')
-rw-r--r--packages/madfu/madfu_1.2.bb28
1 files changed, 13 insertions, 15 deletions
diff --git a/packages/madfu/madfu_1.2.bb b/packages/madfu/madfu_1.2.bb
index be94f4e13b..354e65aced 100644
--- a/packages/madfu/madfu_1.2.bb
+++ b/packages/madfu/madfu_1.2.bb
@@ -3,27 +3,25 @@ LICENSE = "GPL"
PR = "r1"
SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/usb-midi-fw/madfuload-1.2.tar.gz \
- file://autofoo.patch;patch=1"
-inherit autotools
+ file://autofoo.patch;patch=1"
-S = ${WORKDIR}/madfuload-1.2
+S = "${WORKDIR}/madfuload-1.2"
-#EXTRA_OECONF = "--without-udev"
-FILES_${PN} += "${libdir}/firmware/"
+inherit autotools
do_configure() {
- oe_runconf
+ oe_runconf
}
-
do_compile() {
- oe_runmake
+ oe_runmake
}
-
do_install() {
- install -d ${D}/${sbindir}
- install -m 755 ${S}/madfuload ${D}/${sbindir}
- install -d ${D}/${libdir}/firmware
- install -m 644 ${S}/*.bin ${D}/${libdir}/firmware
- install -d ${D}/${sysconfdir}/udev/rules
- install -m 644 ${S}/42-madfuload.rules ${D}/${sysconfdir}/udev/rules
+ install -d ${D}/${sbindir}
+ install -m 755 ${S}/madfuload ${D}/${sbindir}
+ install -d ${D}/${libdir}/firmware
+ install -m 644 ${S}/*.bin ${D}/${libdir}/firmware
+ install -d ${D}/${sysconfdir}/udev/rules
+ install -m 644 ${S}/42-madfuload.rules ${D}/${sysconfdir}/udev/rules
}
+
+FILES_${PN} += "${libdir}/firmware/"