summaryrefslogtreecommitdiff
path: root/packages/madfu/madfu_1.2.bb
diff options
context:
space:
mode:
authorShane Volpe <shanevolpe@gmail.com>2007-04-07 20:23:43 +0000
committerShane Volpe <shanevolpe@gmail.com>2007-04-07 20:23:43 +0000
commit3a5e5c11ca9e5d3686fce546e33eacc62f5e7dcd (patch)
tree4f25aacf8558a773fad14e0018d4afb9f560237f /packages/madfu/madfu_1.2.bb
parent1ff6665ead8253bb6adde2afeb004f9ef625f4f4 (diff)
parent2effa2e0213c0cecaf6d3a0ca7390a288ebc9908 (diff)
merge of '59b19c7d48e754418caf1f4214b1ce53d2cca5c4'
and 'f4a044e0ef8b886ef1bdc74ae09f12874ddf7130'
Diffstat (limited to 'packages/madfu/madfu_1.2.bb')
-rw-r--r--packages/madfu/madfu_1.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/madfu/madfu_1.2.bb b/packages/madfu/madfu_1.2.bb
new file mode 100644
index 0000000000..354e65aced
--- /dev/null
+++ b/packages/madfu/madfu_1.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Firmware loader for m-audio devices"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/usb-midi-fw/madfuload-1.2.tar.gz \
+ file://autofoo.patch;patch=1"
+
+S = "${WORKDIR}/madfuload-1.2"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+do_compile() {
+ oe_runmake
+}
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 755 ${S}/madfuload ${D}/${sbindir}
+ install -d ${D}/${libdir}/firmware
+ install -m 644 ${S}/*.bin ${D}/${libdir}/firmware
+ install -d ${D}/${sysconfdir}/udev/rules
+ install -m 644 ${S}/42-madfuload.rules ${D}/${sysconfdir}/udev/rules
+}
+
+FILES_${PN} += "${libdir}/firmware/"