summaryrefslogtreecommitdiff
path: root/packages/mISDN
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-09 04:07:20 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-09 04:07:20 +0000
commit2c7548a057cd1324169208771a4435fa1304900f (patch)
tree5b9db7fad906b709d2bbb1c9c6a27cf3bc4b76a7 /packages/mISDN
parent193c05e487cda2de96e3836622e9cd6f98c0637e (diff)
misdn: moving to nonworking and resolving bug 240 as LATER
Diffstat (limited to 'packages/mISDN')
-rw-r--r--packages/mISDN/.mtn2git_empty0
-rw-r--r--packages/mISDN/files/.mtn2git_empty0
-rw-r--r--packages/mISDN/files/Makefile4
-rw-r--r--packages/mISDN/files/hfcs_usb_endianchecks.diff58
-rw-r--r--packages/mISDN/misdn_cvs.bb35
5 files changed, 0 insertions, 97 deletions
diff --git a/packages/mISDN/.mtn2git_empty b/packages/mISDN/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/mISDN/.mtn2git_empty
+++ /dev/null
diff --git a/packages/mISDN/files/.mtn2git_empty b/packages/mISDN/files/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/mISDN/files/.mtn2git_empty
+++ /dev/null
diff --git a/packages/mISDN/files/Makefile b/packages/mISDN/files/Makefile
deleted file mode 100644
index bed60110ea..0000000000
--- a/packages/mISDN/files/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-PWD := $(shell pwd)
-SELECTION := CONFIG_MISDN_DRV=m CONFIG_MISDN_DSP=m CONFIG_MISDN_HFCUSB=m
-default modules:
- $(MAKE) -C $(KDIR) SUBDIRS=${PWD}/drivers/isdn/hardware/mISDN/ EXTRA_CFLAGS=-I${PWD}/include modules ${SELECTION}
diff --git a/packages/mISDN/files/hfcs_usb_endianchecks.diff b/packages/mISDN/files/hfcs_usb_endianchecks.diff
deleted file mode 100644
index 1f6ff3fcc8..0000000000
--- a/packages/mISDN/files/hfcs_usb_endianchecks.diff
+++ /dev/null
@@ -1,58 +0,0 @@
---- mISDN.org/drivers/isdn/hardware/mISDN/hfcs_usb.c 2005-06-23 18:43:36.000000000 +0200
-+++ mISDN/drivers/isdn/hardware/mISDN/hfcs_usb.c 2005-08-12 16:16:24.000000000 +0200
-@@ -2038,9 +2038,9 @@
-
- vend_idx = 0xffff;
- for (i = 0; hfcsusb_idtab[i].idVendor; i++) {
-- if (dev->descriptor.idVendor == hfcsusb_idtab[i].idVendor
-+ if (dev->descriptor.idVendor == le16_to_cpu(hfcsusb_idtab[i].idVendor)
- && dev->descriptor.idProduct ==
-- hfcsusb_idtab[i].idProduct) {
-+ le16_to_cpu(hfcsusb_idtab[i].idProduct)) {
- vend_idx = i;
- continue;
- }
-@@ -2160,8 +2160,8 @@
- usb_transfer_mode
- = USB_INT;
- packet_size =
-- ep->desc.
-- wMaxPacketSize;
-+ le16_to_cpu(ep->desc.
-+ wMaxPacketSize);
- break;
- case USB_ENDPOINT_XFER_BULK:
- if (ep_addr & 0x80)
-@@ -2189,8 +2189,8 @@
- usb_transfer_mode
- = USB_BULK;
- packet_size =
-- ep->desc.
-- wMaxPacketSize;
-+ le16_to_cpu(ep->desc.
-+ wMaxPacketSize);
- break;
- case USB_ENDPOINT_XFER_ISOC:
- if (ep_addr & 0x80)
-@@ -2218,8 +2218,8 @@
- usb_transfer_mode
- = USB_ISOC;
- iso_packet_size =
-- ep->desc.
-- wMaxPacketSize;
-+ le16_to_cpu(ep->desc.
-+ wMaxPacketSize);
- break;
- default:
- card->
-@@ -2234,8 +2234,8 @@
- card;
- card->fifos[cidx].
- usb_packet_maxlen =
-- ep->desc.
-- wMaxPacketSize;
-+ le16_to_cpu(ep->desc.
-+ wMaxPacketSize);
- card->fifos[cidx].
- intervall =
- ep->desc.bInterval;
diff --git a/packages/mISDN/misdn_cvs.bb b/packages/mISDN/misdn_cvs.bb
deleted file mode 100644
index 865e41b2f9..0000000000
--- a/packages/mISDN/misdn_cvs.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-DESCRIPTION = "mISDN kernel packages"
-PRIORITY = "optional"
-SECTION = "kernel/modules"
-LICENSE = "GPL"
-PR = "r0"
-
-DEFAULT_PREFERENCE = "-1"
-
-# hfcs_usb_endianchecks.diff does not apply cleanly anymore (cf. bug 240)
-# without it the package at least compiles. no guarantees about functionality.
-SRC_URI = "cvs://anonymous:readonly@cvs.isdn4linux.de/i4ldev;module=mISDN;method=pserver \
-# file://hfcs_usb_endianchecks.diff;patch=1 \
- file://Makefile"
-
-S = "${WORKDIR}/mISDN/"
-
-inherit module
-
-do_compile_prepend() {
- cp -f ${WORKDIR}/Makefile ${S}/
- cp ${S}/drivers/isdn/hardware/mISDN/Makefile.v2.6 ${S}/drivers/isdn/hardware/mISDN/Makefile
-}
-
-do_compile () {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
- 'CC=${KERNEL_CC}' \
- 'LD=${KERNEL_LD}'
-}
-
-do_install() {
- install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/isdn/hardware/mISDN/
- install -m 0644 ${S}/drivers/isdn/hardware/mISDN/*${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/isdn/hardware/mISDN
-}
-