summaryrefslogtreecommitdiff
path: root/packages/ltp/ltp_20070228.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-03-10 13:53:44 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-03-10 13:53:44 +0000
commit4e1b3553413ad9c600123f6e3acd1468cf4760cb (patch)
tree84666ed44ed4b8012fad7dae152685f20693af42 /packages/ltp/ltp_20070228.bb
parent6f9a198964d8d694926f780076319591b47afdbd (diff)
ltp: added 20070228 version of Linux Test Project (based by recipe from CELF)
- package has 23M compressed (can be improved)
Diffstat (limited to 'packages/ltp/ltp_20070228.bb')
-rw-r--r--packages/ltp/ltp_20070228.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/ltp/ltp_20070228.bb b/packages/ltp/ltp_20070228.bb
new file mode 100644
index 0000000000..400d642641
--- /dev/null
+++ b/packages/ltp/ltp_20070228.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Linux Test Project"
+HOMEPAGE = "http://ltp.sourceforge.net"
+LICENSE = "GPL"
+SECTION = "console/utils"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.tgz \
+ file://cross-compile.patch;patch=1 \
+ file://runltp-path.patch;patch=1 \
+ file://ltp-run"
+
+S = "${WORKDIR}/ltp-full-${PV}"
+
+EXTRA_OEMAKE_append = " CROSS_COMPILE=${HOST_PREFIX}"
+
+do_compile(){
+ oe_runmake CROSS_COMPILE=${HOST_PREFIX}
+}
+
+do_install(){
+ export CREATE=0
+ export LTPROOT=${D}/usr/libexec/ltp/testcases
+
+ oe_runmake install
+
+ install -d ${D}/usr/libexec/ltp/testcases
+ install -d ${D}/usr/libexec/ltp/pan
+
+ #install testcases
+ #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/testcases
+ #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/
+
+ # treecopy testcases pan/pan runtest ver_linux IDcheck.sh \
+ # ${D}/usr/libexec/ltp
+ cp testcases ${D}/usr/libexec/ltp/ -rfp
+ rm ${D}/usr/libexec/ltp/ballista -rf
+ cp pan/pan ${D}/usr/libexec/ltp/pan -p
+ cp runtest ${D}/usr/libexec/ltp/ -rfp
+ cp ver_linux ${D}/usr/libexec/ltp/ -p
+ cp runltp ${D}/usr/libexec/ltp/ -p
+ cp IDcheck.sh ${D}/usr/libexec/ltp/ -p
+}
+