summaryrefslogtreecommitdiff
path: root/packages/ltp/ltp-20080229
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2008-02-29 23:40:40 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2008-02-29 23:40:40 +0000
commit07b305be5bd9ab2ae6bed80d81faf2b6f16a3a49 (patch)
treea0f78471c31dd1834b83154648045e6748775a69 /packages/ltp/ltp-20080229
parent3db46e12e6f48196f5e80b3bb14b3ebfc1993bf9 (diff)
ltp-20080229: Newly arrived, the leap day surprise.
Diffstat (limited to 'packages/ltp/ltp-20080229')
-rw-r--r--packages/ltp/ltp-20080229/.mtn2git_empty0
-rw-r--r--packages/ltp/ltp-20080229/cross-compile.patch31
-rw-r--r--packages/ltp/ltp-20080229/ltp-run4
-rw-r--r--packages/ltp/ltp-20080229/posix_shell_compat.patch33
-rw-r--r--packages/ltp/ltp-20080229/runltp-path.patch24
5 files changed, 92 insertions, 0 deletions
diff --git a/packages/ltp/ltp-20080229/.mtn2git_empty b/packages/ltp/ltp-20080229/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ltp/ltp-20080229/.mtn2git_empty
diff --git a/packages/ltp/ltp-20080229/cross-compile.patch b/packages/ltp/ltp-20080229/cross-compile.patch
new file mode 100644
index 0000000000..4aa4eefd18
--- /dev/null
+++ b/packages/ltp/ltp-20080229/cross-compile.patch
@@ -0,0 +1,31 @@
+Index: ltp-full-20080229/Makefile
+===================================================================
+--- ltp-full-20080229.orig/Makefile 2008-02-29 08:55:41.000000000 +0100
++++ ltp-full-20080229/Makefile 2008-03-01 00:27:33.000000000 +0100
+@@ -33,11 +33,12 @@
+ endif
+ ifdef CROSS_COMPILER
+ CC=$(CROSS_COMPILER)gcc
++CPP=$(CROSS_COMPILER)g++
+ AR=$(CROSS_COMPILER)ar
+ endif
+
+ export CFLAGS += -Wall $(CROSS_CFLAGS)
+-export CC AR LDFLAGS
++export CC AR LDFLAGS CPP
+
+ -include config.mk
+
+Index: ltp-full-20080229/testcases/ballista/ballista/Makefile
+===================================================================
+--- ltp-full-20080229.orig/testcases/ballista/ballista/Makefile 2008-02-29 08:55:46.000000000 +0100
++++ ltp-full-20080229/testcases/ballista/ballista/Makefile 2008-03-01 00:27:33.000000000 +0100
+@@ -24,7 +24,7 @@
+ ########################
+
+ # compiler info for the host
+-CC = g++ -Wno-deprecated
++CC = $(CPP) -Wno-deprecated
+ CFLAGS = -w -O ${TARGET_DEF}
+ CLIBS = -lpthread -ldl -lnsl -rdynamic
+ TEST_MAN_FILE = selfHost
diff --git a/packages/ltp/ltp-20080229/ltp-run b/packages/ltp/ltp-20080229/ltp-run
new file mode 100644
index 0000000000..5d97f00532
--- /dev/null
+++ b/packages/ltp/ltp-20080229/ltp-run
@@ -0,0 +1,4 @@
+#!/bin/sh
+/usr/libexec/ltp/runltp -t 180s > /home/root/testlog.txt
+echo "Benchmark run finished...."
+touch /home/root/testfinished.flag
diff --git a/packages/ltp/ltp-20080229/posix_shell_compat.patch b/packages/ltp/ltp-20080229/posix_shell_compat.patch
new file mode 100644
index 0000000000..b88d598deb
--- /dev/null
+++ b/packages/ltp/ltp-20080229/posix_shell_compat.patch
@@ -0,0 +1,33 @@
+Index: ltp-full-20080229/testcases/network/generate.sh
+===================================================================
+--- ltp-full-20080229.orig/testcases/network/generate.sh 2008-03-01 00:34:24.000000000 +0100
++++ ltp-full-20080229/testcases/network/generate.sh 2008-03-01 00:35:13.000000000 +0100
+@@ -53,22 +53,24 @@
+ $makeit $data_dir/$jumbo_file $jumbo_size
+
+ if [ ! -e $data_dir/bin.sm ] ; then
+- cnt=6
+- while [ $((cnt=cnt-1)) -ge 0 ] ; do
++ cnt=5
++ while [ $cnt -ge 0 ] ; do
+ gzip -1 -c datafiles/ascii.sm >> $data_dir/bin.sm
++ cnt=$(($cnt-1))
+ done
+ fi
+
+ genfile() {
+ local input=$data_dir/$1 output=$data_dir/$2
+- local cnt=20
++ local cnt=19
+
+ if [ -e $output ] ; then
+ return 0
+ fi
+
+- while [ $((cnt=cnt-1)) -ge 0 ] ; do
++ while [ $cnt -ge 0 ] ; do
+ cat $input >> $output
++ cnt=$(($cnt-1))
+ done
+ }
+
diff --git a/packages/ltp/ltp-20080229/runltp-path.patch b/packages/ltp/ltp-20080229/runltp-path.patch
new file mode 100644
index 0000000000..d117b3c24e
--- /dev/null
+++ b/packages/ltp/ltp-20080229/runltp-path.patch
@@ -0,0 +1,24 @@
+Index: runltp
+===================================================================
+--- ltp-full-20060412.orig/runltp 2005-03-12 03:26:14.000000000 +0800
++++ ltp-full-20060412/runltp 2006-04-26 16:42:13.000000000 +0800
+@@ -43,7 +43,7 @@
+ echo "FATAL: unable to change directory to $(dirname $0)"
+ exit 1
+ }
+- export LTPROOT=${PWD}
++ export LTPROOT=/usr/libexec/ltp
+ export TMPBASE="/tmp"
+ export TMP="${TMPBASE}/ltp-$$"
+ export PATH="${PATH}:${LTPROOT}/testcases/bin"
+--- ltp-full-20060412.orig/runltp 2007-02-28 20:40:17.000000000 -0800
++++ ltp-full-20060412/runltp 2007-04-01 11:38:38.000000000 -0700
+@@ -285,7 +285,7 @@
+ ${LTPROOT}/runtest/sched ${LTPROOT}/runtest/math \
+ ${LTPROOT}/runtest/nptl ${LTPROOT}/runtest/pty
+ do
+- [ -a "$SCENFILES" ] || \
++ [ -e "$SCENFILES" ] || \
+ {
+ echo "FATAL: missing scenario file $SCENFILES"
+ exit 1