summaryrefslogtreecommitdiff
path: root/packages/llvm/llvm_2.4.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2009-01-24 11:35:43 +0100
committerRobert Schuster <thebohemian@gmx.net>2009-01-24 11:35:43 +0100
commit53dcbe3b9b6059ef3c8432007ab2bc1e718cb9a6 (patch)
tree7fd785ed9406667e2a294c8178fbb3283aad74d0 /packages/llvm/llvm_2.4.bb
parentfb189177751dcbfef4ad7cecfe5f62a54a414010 (diff)
llvm: Various fixes.
* only build backend for the target machine * suppress automatic stripping * added patch to fix C++ "static initialization order fiasco"
Diffstat (limited to 'packages/llvm/llvm_2.4.bb')
-rw-r--r--packages/llvm/llvm_2.4.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/packages/llvm/llvm_2.4.bb b/packages/llvm/llvm_2.4.bb
index c1ad694ae6..a66d1b376b 100644
--- a/packages/llvm/llvm_2.4.bb
+++ b/packages/llvm/llvm_2.4.bb
@@ -5,12 +5,17 @@ LICENSE = "various"
SRC_URI = "\
http://llvm.org/releases/${PV}/llvm-${PV}.tar.gz \
file://fix-build.patch;patch=1 \
+ file://fix-static-initialization.patch;patch=1 \
"
DEPENDS = "llvm-native"
inherit autotools
+# --enable-debug-runtime disables automatic stripping and lets
+# OE control that
+EXTRA_OECONF += "--enable-debug-runtime --enable-targets=host-only"
+
do_compile() {
# The build wants these binaries, together with the build-fix patch
# they are not compiled again (which would not work).