summaryrefslogtreecommitdiff
path: root/packages/llvm/llvm_2.4.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2009-01-16 03:25:59 +0100
committerRobert Schuster <thebohemian@gmx.net>2009-01-16 03:25:59 +0100
commit01d608c6f5fa927d20385005f9438e63ac673280 (patch)
tree13333bf47212cd33fc15304b90976e42cbd7d21c /packages/llvm/llvm_2.4.bb
parent85fc507c227d93c06ee519c332793f518f60203f (diff)
llvm 2.4: More cleanly disable the compilation (fixes compiling on amd64).
Diffstat (limited to 'packages/llvm/llvm_2.4.bb')
-rw-r--r--packages/llvm/llvm_2.4.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/packages/llvm/llvm_2.4.bb b/packages/llvm/llvm_2.4.bb
index d06e4a3f74..c1ad694ae6 100644
--- a/packages/llvm/llvm_2.4.bb
+++ b/packages/llvm/llvm_2.4.bb
@@ -12,14 +12,13 @@ DEPENDS = "llvm-native"
inherit autotools
do_compile() {
- # tblgen doesnt want to link correctly. Pull the one in we have in staging.
+ # The build wants these binaries, together with the build-fix patch
+ # they are not compiled again (which would not work).
+ # Most important aspect is removing BUILD_TARGET_DIRS variable.
install -d Release/Build/bin
cp ${STAGING_BINDIR_NATIVE}/tblgen Release/Build/bin
cp ${STAGING_BINDIR_NATIVE}/fpcmp Release/Build/bin
cp ${STAGING_BINDIR_NATIVE}/llvm-PerfectShuffle Release/Build/bin
- install -d Release/Build/lib
- touch Release/Build/lib/libLLVMSupport.a
- touch Release/Build/lib/libLLVMSystem.a
oe_runmake
}