summaryrefslogtreecommitdiff
path: root/packages/lirc
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-02 21:40:10 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-02 21:40:10 +0000
commit5c889a3bff1539bf19b368a1739f592ef456aaef (patch)
tree5b67d2e4641df99cbbfc917cbdfb42b64e512465 /packages/lirc
parent12e598e0e41627e926fa40fef739772adb94de71 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/06/02 22:13:59+01:00 reciva.com!pb Merge bk://oe-devel@openembedded-devel.bkbits.net/openembedded into mill.internal.reciva.com:/nexus/home/pb/oe/oe 2005/06/02 22:07:26+01:00 reciva.com!pb factor out lirc machine specifics into an .inc file. avoid feeding LDFLAGS to the kernel linker, since it doesn't like them. 2005/06/02 22:59:55+02:00 utwente.nl!koen nokia770.conf: remove arm926ejs from archs 2005/06/02 22:56:13+02:00 utwente.nl!koen tune-arm926ejs.conf: set arch to armv5te instead of arm926ejs as Phil pointed out BKrev: 429f7cbanu_8PuI52mw_rYQD7m0Dkg
Diffstat (limited to 'packages/lirc')
-rw-r--r--packages/lirc/lirc-config.inc0
-rw-r--r--packages/lirc/lirc-modules_0.7.0.bb10
-rw-r--r--packages/lirc/lirc_0.7.0.bb6
3 files changed, 4 insertions, 12 deletions
diff --git a/packages/lirc/lirc-config.inc b/packages/lirc/lirc-config.inc
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/lirc/lirc-config.inc
diff --git a/packages/lirc/lirc-modules_0.7.0.bb b/packages/lirc/lirc-modules_0.7.0.bb
index 7e63c561fc..99b0fabd31 100644
--- a/packages/lirc/lirc-modules_0.7.0.bb
+++ b/packages/lirc/lirc-modules_0.7.0.bb
@@ -12,15 +12,11 @@ S = "${WORKDIR}/lirc-${PV}"
inherit autotools module-base
-EXTRA_OECONF = "--with-kerneldir=${STAGING_KERNEL_DIR}"
-EXTRA_OECONF_append_epia = " --with-driver=serial"
-EXTRA_OECONF_append_collie = " --with-driver=sa1100 --without-x"
-EXTRA_OECONF_append_h3600 = " --with-driver=sa1100 --without-x"
-EXTRA_OECONF_append_beagle = " --with-driver=sa1100 --without-x"
-EXTRA_OECONF_append_simpad = " --with-driver=sa1100 --without-x"
+include lirc-config.inc
do_compile() {
- cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}"
+ # ${KERNEL_LD} doesn't understand the LDFLAGS, so suppress them
+ cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" LDFLAGS=""
}
fakeroot do_install() {
diff --git a/packages/lirc/lirc_0.7.0.bb b/packages/lirc/lirc_0.7.0.bb
index 4de5432aae..3ab40a60d2 100644
--- a/packages/lirc/lirc_0.7.0.bb
+++ b/packages/lirc/lirc_0.7.0.bb
@@ -16,11 +16,7 @@ inherit autotools module-base update-rc.d
INITSCRIPT_NAME = "lirc"
INITSCRIPT_PARAMS = "defaults 20"
-EXTRA_OECONF_epia = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=serial"
-EXTRA_OECONF_collie = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
-EXTRA_OECONF_h3600 = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
-EXTRA_OECONF_beagle = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
-EXTRA_OECONF_simpad = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+include lirc-config.inc
EXTRA_OEMAKE = 'SUBDIRS="daemons tools"'