summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2005-06-05 14:38:13 +0000
committerRod Whitby <rod@whitby.id.au>2005-06-05 14:38:13 +0000
commita7fa049c3d61d12801999b739ae4743665ed3765 (patch)
treea8540447a28ae31e27f6b62ff7de51549688afe6 /packages/linux
parent5cf10fc629fbc01240b1d2defee82cb29541af7c (diff)
Removed the ?= for CMDLINE_ROOT for the Unslung kernel
BKrev: 42a30e55XWvxRnlC6bwPo2uj8MdGWw
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/unslung-kernel_2.3r25.bb4
-rw-r--r--packages/linux/unslung-kernel_2.3r29.bb34
2 files changed, 36 insertions, 2 deletions
diff --git a/packages/linux/unslung-kernel_2.3r25.bb b/packages/linux/unslung-kernel_2.3r25.bb
index 87b1dd9968..99bf69abf8 100644
--- a/packages/linux/unslung-kernel_2.3r25.bb
+++ b/packages/linux/unslung-kernel_2.3r25.bb
@@ -4,11 +4,11 @@ include nslu2-linksys-kernel_2.4.22.bb
DESCRIPTION = "Unslung kernel for the Linksys NSLU2 device"
MAINTAINER = "NSLU2 Linux <www.nlsu2-linux.org>"
-PR = "r18"
+PR = "r19"
KERNEL_SUFFIX = "unslung"
-CMDLINE_ROOT ?= "root=/dev/mtdblock4 rootfstype=jffs2 rw init=/linuxrc mem=32M@0x00000000"
+CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 rw init=/linuxrc mem=32M@0x00000000"
UNSLUNG_KERNEL_EXTRA_SRC_URI ?=
diff --git a/packages/linux/unslung-kernel_2.3r29.bb b/packages/linux/unslung-kernel_2.3r29.bb
index e69de29bb2..3bfa0e7ffb 100644
--- a/packages/linux/unslung-kernel_2.3r29.bb
+++ b/packages/linux/unslung-kernel_2.3r29.bb
@@ -0,0 +1,34 @@
+SECTION = "kernel"
+
+include nslu2-linksys-kernel_2.4.22.bb
+
+DESCRIPTION = "Unslung kernel for the Linksys NSLU2 device"
+MAINTAINER = "NSLU2 Linux <www.nlsu2-linux.org>"
+PR = "r1"
+
+KERNEL_SUFFIX = "unslung"
+
+CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 rw init=/linuxrc mem=32M@0x00000000"
+
+UNSLUNG_KERNEL_EXTRA_SRC_URI ?=
+
+SRC_URI += "file://limit1gb.patch;patch=1 \
+ file://gl811e.patch;patch=1 \
+ file://ext3flash-on-disk1.patch;patch=1 \
+ file://usbnet.patch;patch=1 \
+ file://missing-usb-ioctls.patch;patch=1 \
+ file://anonymiser.patch;patch=1 \
+ file://ppp_mppe.patch;patch=1 \
+ file://nfs-blocksize.patch;patch=1 \
+ file://pl2303.patch;patch=1 \
+ ${UNSLUNG_KERNEL_EXTRA_SRC_URI}"
+
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/unslung-kernel', '${FILE_DIRNAME}/nslu2-linksys-kernel-2.4.22', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+
+python () {
+ # Don't build unslung kernel unless we're targeting an nslu2
+ mach = bb.data.getVar("MACHINE", d, 1)
+ dist = bb.data.getVar("DISTRO", d, 1)
+ if mach != 'nslu2' or dist != 'unslung':
+ raise bb.parse.SkipPackage("Unslung only builds for the Linksys NSLU2")
+}